Part Edit crashes

1rst Time using Fritzing, 1st time using Part Editor
I need a new part, Shelly Uni.

just played a little with parts editor
started fritzing
click on breadboard
click on core part , generic resistor
click on Part Edit
click on Schematic
deleted X Connector Pins
click 3 times on a deleted connector Fritzing crashes

Tried with different parts

My version of Fritzing and my operating system:

Windows 11, Fritzing 1.0.1

You are best to report this here on github (which is the official bug repository)

You also need more details on how to reproduce this. I just tried what you describe and while I don’t often use parts editor I can’t see a way to delete the pin in schematic. The delete key doesn’t appear to work so a description of exactly the series of steps you took will likely be required.


delete key will not work i’m using the x

And it happens every time and every part i tried it

Yep, appears to be a bug as it happens to me as well. These tutorials on parts creation may help:

I lately learned there aren’t links to the videos in Old_Grey’s tutorial so you need to do a google search for the title and then they come up on YouTube.

As noted mine doesn’t use parts editor, but in general parts creation is difficult and if you only need a part or two not really worth learning. For small numbers of parts you are better off to let one of us who is familiar with part creation make it for you by posting a request and a datasheet (with dimension and connection information for the part.)