Linux fails on fatal IO error 2

When i try to run Fritzing nothing happens, and when I try to run it from the terminal the loading window briefly appears and then this error is displayed in the terminal: QSslSocket: cannot resolve SSLv2_client_method QSslSocket: cannot resolve SSLv2_server_method
The X11 connection broke: Maximum allowed requested length exceeded (code 4)
XIO:  fatal IO error 2 (Adresář nebo soubor neexistuje) on X server ":0"
      after 509 requests (505 known processed) with 0 events remaining.
Segmentation fault (core dumped)

tried a lot of stuff by now, nothing to find anywhere (tried to DDG it and google it many times, also tried to find something on the forums), i tried to redownload it a dozen times, but nothing helps.
thanks for help

I want to ask a couple of questions:

What version of Fritzing are you trying to use?
Was it installed with the DE package manager/

I downloaded the latest Linux .tar.bz2 file. I believe it was 0.9.3b and i untared it using Ubuntu 16.10 native package manager.

From the unatred directory, you have to nstall it. running:


then from the same directing type


I don’t have my other computer here with 0.9.3b on it. But give this a go.

Well, i tried that, but it tells me, it can’t find the program even after i install it.
Also i tried installing it from apt
sudo apt install fritzing

and when i try to run it then it gives sigsegv.

(i got my system in czech, so it wouldn’t make any sense if i pasted the stuff it told me here)

you would need to use this

$sudo apt-get install fritzing

That would install the one in the repos of your distro. Which would version 0.9.0 probably.

Is your computer system all in Czech?

What distribution are you using? Sounds like a dependency problem… Without said library Fritzing segfaults.

Assuming you extracted fritzing in your Downloads folder try running ldd on fritzing to see whats missing
ie; command shell of your choice.

cd ~//Downloads/fritzing-0.9.3b.linux.AMD64/lib/
(or directory extracted to then cd to /lib folder)
ldd Fritzing

You should see and output similar to this. => (0x00007ffc9b38a000) => /lib/x86_64-linux-gnu/ (0x00007fe91b04f000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe91ad29000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe91aad5000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe91a868000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe919ff5000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe9197fe000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe9195c3000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe919263000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe91901f000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe918e06000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe9186f3000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe918371000) => /lib/x86_64-linux-gnu/ (0x00007fe918068000) => /lib/x86_64-linux-gnu/ (0x00007fe917e52000) => /lib/x86_64-linux-gnu/ (0x00007fe917a88000) => /lib/x86_64-linux-gnu/ (0x00007fe91781f000) => /lib/x86_64-linux-gnu/ (0x00007fe9173db000) => /lib/x86_64-linux-gnu/ (0x00007fe9171d2000) => /lib/x86_64-linux-gnu/ (0x00007fe916fb5000) => /usr/lib/x86_64-linux-gnu/mesa/ (0x00007fe916d44000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe916af0000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe9168ee000) => /lib/x86_64-linux-gnu/ (0x00007fe9165dc000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe9163ca000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe916090000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe915bf5000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe91583d000) => /home/sysadmin/Downloads/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007fe913e59000) => /lib/x86_64-linux-gnu/ (0x00007fe913c55000)
/lib64/ (0x000055c7533e0000) => /lib/x86_64-linux-gnu/ (0x00007fe913a2b000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe913828000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe913625000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe91341d000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe91321a000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe912fec000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe912de8000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe912be2000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe9129e0000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe9127c6000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe9125c1000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe91239f000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe912198000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe911f89000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe911d80000) => /lib/x86_64-linux-gnu/ (0x00007fe911b10000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe91190c000) => /usr/lib/x86_64-linux-gnu/ (0x00007fe911705000)

Give it a try, see what you get.

My system is all in Czech, but it’s not 100% translated, so the command line gives a mix of Czech and English.
I am using Ubuntu 16.10.
I’ll give a try to landracers solution once i get home.
Thanks a lot so far.

$ idd Fritzing

gave: => (0x00007ffffeff9000) => /lib/x86_64-linux-gnu/ (0x00007f3ab5f16000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab5bf1000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab599d000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab5730000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab4ebe000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab46c5000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab448a000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab412b000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab3ee7000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab3cce000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab35bc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3ab3232000) => /lib/x86_64-linux-gnu/ (0x00007f3ab2f29000) => /lib/x86_64-linux-gnu/ (0x00007f3ab2d12000) => /lib/x86_64-linux-gnu/ (0x00007f3ab294b000) => /lib/x86_64-linux-gnu/ (0x00007f3ab26e2000) => /lib/x86_64-linux-gnu/ (0x00007f3ab229e000) => /lib/x86_64-linux-gnu/ (0x00007f3ab2094000) => /lib/x86_64-linux-gnu/ (0x00007f3ab1e76000) => /usr/lib/x86_64-linux-gnu/mesa/ (0x00007f3ab1c02000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3ab19af000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3ab17ad000) => /lib/x86_64-linux-gnu/ (0x00007f3ab149a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3ab1286000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3ab0f4d000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab0ab3000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3ab06fb000) => /home/jan/Stažené/fritzing-0.9.3b.linux.AMD64/lib/./ (0x00007f3aaed18000) => /lib/x86_64-linux-gnu/ (0x00007f3aaeb12000)
/lib64/ (0x000055b7bcc6b000) => /lib/x86_64-linux-gnu/ (0x00007f3aae8e8000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aae6e5000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aae4e2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aae2db000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aae0d6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aadea7000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aadca4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aada9e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aad89c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aad683000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aad47c000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aad25a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aad054000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aace45000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aacc3d000) => /lib/x86_64-linux-gnu/ (0x00007f3aac9ca000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aac7c4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f3aac5be000)

the version installed by sudo apt install fritzing was 0.9.2b

Your package manager must a more up to date packages than mine. I’m running Debian Jessie Stable.

You can uninstall the 0.9.2 with the package manager and the proceed with the installation of the 0.9.3b.

A suggestion about your error messages: while I’ve never run a non english system and thus haven’t tried this, I think you should be able to change the language back to english in a config file somewhere (probably in the localle package) and then reboot and your error messages should come out in english to be posted. With english error messages / logs I expect you will find it a lot easier to get help for any unix problem not just Fritzing.

Do you know about a way of changing the language of the terminal without changing the language of the rest of the OS?

No, I doubt there is one (but am far from an expert on the localle stuff). I think the change is all or nothing (or at least everything that has localle support) and probably requires a boot to change it but as far as I know it is a boot time option so you should (with the note I haven’t done it) be able to switch languages with a boot and then switch back.


In terminal try typing
export LANG=C

Do both versions 0.9.2b and 0.9.3b of fritzing segfualt the same way?

Yes, both segfault the same way.

Is openssl installed on the system? I see were in one Google post the lib lbsssl- was installed and it fixed their problem.

Just a thought.

did you ever try by chance?

sudo apt-get build-dep fritzing

I got libssl1.0.0 installed on version 1.0.2g-1ubuntu9.
And openssl is also installed on version 1.0.2g-1ubuntu9.