Parts couldn't be shown after installing on UBUNTU

I have installed Fritzing on Ubuntu, it could run, but the parts was empty.

When I double-click Fritzing snd open it, 3 prompts windows came continuously after each “OK”

I tried to download the parts file here:

But, it was “.fzp” extension. not “.fzb”, so the Fritzing IDE couldn’t find any file in the directory,
did anyone else has solute this problem?

The parts are a github repository, so you need to clone it in to the appropriate place. Fritzing won’t load it for itself. Did you download the tar file from the Fritzing site or use one of the application repositories for Ubuntu? The easiest way is to download the tar file from the Fritzing site (which has the correct parts repo already installed), but it isn’t in the package management system. Some of the package management systems either don’t have a dependency for the parts repo, or install it in a place where Fritzing can’t update it (which breaks automatic part updating.) I’d suggest that you clear the user directories (which won’t be affected by a reinstall and may be corrupted from the initial install) and try again, making sure if using a package manager that you have both Fritzing and the parts repository before starting Fritzing. Note on startup Fritzing checks the repository against github looking for updates, and appears to hang. Interrupting it is the usual way of corrupting the user directories.

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you wan to keep something in them.






I download a parts library from github, but it was .fzp file, not .fzb file.

That screenshot is showing the “core” folder from the parts library. The full library is the next level up. In your view, the “fritzing-parts-develop” folder, which should contain several folders. bins, contrib, core, obsolete, scripts, svg, user. The .fzb files are in the bins folder. As long as Fritzing is pointed to the fritzing-parts-develop folder as the parts library, it will find all of the pieces.

There is not quite enough information here about how you installed Fritzing, and where it is expecting to find files. The normal parts folder would be “fritzing-parts” (or just “parts”), not “fritzing-parts-develop”. However, if you start fritzing from the command line (terminal window), you can tell Fritzing where to get the parts. From your screen shot,

fritzing --parts "$HOME/Documents/Fritzing/fritzing-parts-develop"

should do the job. There are other ways of getting the same result, but that needs more information about how Fritzing is being installed and run. I am using Fritzing on Fedora, and I know of 3 different ways that can (typically) be used for the install and run, each with a different way to do this sort of fix generically. And I am not a linux expert.

I believe by default github is downloading the development branch of the parts repository (which is why the fritzing-parts-develop) you want to copy that in to where ever Fritzing is expecting your parts repository (if you loaded from the distribution tar ball that would be install-directory/fritzing-parts. This is Windows rather than Linux, but the directory layout for the download version is the same:

You want to copy fritzing-parts-develop in to fritzing-parts in this example (you will need to use cp -R to get the subdirectories.) Your easiest solution may be to download the tar file from the download site and untar it. It contains the correct parts library in the correct place (but is not under your package manager) and usually just works. If you have installed from your package manager either a

find / -name fritzing-parts -print

(which should give you the path to fritzing-parts) or trying to install fritzing-parts from your app manager may do the trick (some of the app manager packages do not install the parts by default, and that breaks Fritzing.) You may need to clear the user directories before doing this as they may be corrupted by the lack of a proper parts repository.


Thanks, it works.

Thanks, your proposal is also worthy of trying, since I have found back the parts, so let me drawing for some emergent circuit first, and then I would try your solution sometime.

Excuse me, here is a new question, why the code

“fritzing --parts “$HOME/Documents/Fritzing/fritzing-parts-develop””

could be used once, next time, when I input it, the same prompts appears again.

I do not know what prompts you are getting. When I use that, it just starts the program … or did you mean the console messages? There are several pieces of status and debug information logged to the terminal window as the program is starting, and more while the program is running. These are shown each time the program is started, and in several other situations. Like opening a sketch file.

There were 2 loading course, when I picked it, it prompted:
Unable to find the following 157 parts.

So, when I closed the prompt, the interface was thus.

and when I opened Fritzing, imported into it from the directory I download “fritzing-part-development”, it show thus.

That looks like you have an old or corrupt version of the parts library. The command line allows it to be found, but it is old or bad. In a terminal window, change to the fritzing-parts-develop folder, and run

git remote -v
git status
git log

git log could provide pages of information. just press “q” at the end of the first page. That will show where the information is coming from, what and when the latest updates were done to the parts. If that is not February of this year, it is out of date.

That will not work if you do not have the git program installed. It will also probably not work if that folder was created from a zip download of the parts library. I think the zip download does not get the git information.

What do you mean by “imported from the directory”? That sounds like it might be a mix up between the core parts library and adding custom parts. The core parts are not imported. That is what the “–parts” option is supposed to handle. It tells Fritzing where the core parts library is, so that it knows where to look for all of those parts that it says can not be found.

The screenshot provided with the

post shows what looks like a good start of Fritzing, with the core parts on the right. Then the latest set of screen shots show different and missing information. Did you try to import the parts folder after it was already loaded?

I have not reload the library, last time, after I drawing, I just close the software and leave.

When I start Fritzing in CLI, it would create “fritzing” directory in /Home/Documents after I had deleted it.
So, this time I download “fritzing-parts-development” again from github and use the command you gave me again.