Parts couldn't be shown after installing on UBUNTU

I deleted the 2 directories when I start Fritzing, and copied the library into it, but this time, the library couldn’t run even once.

So, ,my question is:
I have installed Fritzing on Ubuntu by “sudo apt-get install fritzing”, it was OK when I open it, but the parts was not there, and I download a zip file from github, extracted it, but the Fritzing could not find them.

I have used the command line:“fritzing --parts”/HOME/Documents/…", it was work, but could only work for one time.

And I have seen in Fritzing website, it asked user pay 8 EURO for it, is this the reason ?

I believe that the version that apt-get will install, is 0.9.3b. What you can get from the web site is currently 0.9.4b. There have been changes that could be the cause of some of the problems you have seen. If apt-get did install 0.9.4, the problem is probably that you did not wait after starting fritzing the first time. On initial startup, the parts library does not exist. It is not installed with the application. The first thing Fritzing does is go get it, but that takes time. (it is not a small library) Aborting that, because it looks broken with no parts, ends up with a broken library.

The screen shot shows that you ran frizting without specifying “–parts” to point to the downloaded library. From those messages, whatever configuration Fritzing is using was looking for the library as being your home folder. That is the home folder BEING the library, not the library IN the home folder. Since that is (I expect) wrong, the parts library folders it is trying to use do not exist.

You mentioned downloading the parts library again. That post showed a different name for the library folder than before. Did you change the argument after “–parts” to point to where the folder is after the new download?

More options: delete all of the manually downloaded parts library folders, and (if it exists) the “fritzing” (or "Fritzing) folder inside the documents folder. “sudo apt-get uninstall fritzing”. Verify the fritzing related folders are gone. “sudo apt-get install fritzing”. start Fritzing. WAIT. Go for coffee. Go for lunch if needed. You should get a message (assuming version 0.9.4) that the parts library has been downloaded, or that it could not be downloaded. I do not know for sure what the configuration is set to for the app install on Ubuntu, but that probable creates a “Fritzing” folder inside of Documents, and a “parts” folder inside of that. And that parts folder is where Fritzing will look by default, if you are not using the “–parts” option to tell it different.

Another option is to uninstall the exiting Fritzing app as above, then install the version from Flathub instead. That is what I am using (on Fedora, not Ubuntu). It takes a bit more work on Ubuntu to get flatpak installed, but that will get version 0.9.4b, if apt-get only sees 0.9.3b. That installation also has problems get the parts library updated. I use a manually downloaded parts library (using git instead of zip), plus a small script file that points to it, so I do not need to type it in each time.

#! /bin/sh
flatpak run --env=QT_QPA_PLATFORM=xcb org.fritzing.Fritzing --parts "$HOME/Documents/data_files/fritzing-parts" "$@" &

Where my manually download is the “fritzing-parts” folder, stored in “Documents/data_files”. The platform part of that, is to tell flatpak to run Fritzing with X11 instead of Wayland. I had some glitches previously where the currently used version of QT (needed by Fritzing) was not compatible with the current version of Wayland on Fedora.

I just uninstall and install again Fritzing by “Ubuntu Software”. Should I click “launch” or not ?

I clicked “Launch”, and the 3 error prompts appeared again, should I waiting ?

I do not recall that screen when I started up. It includes ubuntu specific information. It does show version 0.9.3b though, so I do not think the parts library will do the automatic update I was talking about. There should still BE a parts library, but it will be out of date.

Likely nothing to wait for with that version.

It was prompted just now, Fritzing from Flathub couldn’t be installed on Ubuntu, so I installed it from “Ubuntu Software” again. Since the file was just a little more than 8 M, the parts surely not included.

To install from flathub, you first need to have flatpak installed. Which is not quite standard, but is supposed to be available.

Yes, I installed it as it was said in its homepage, but:

Just now, I copied “fritzing-parts-development” into:

Now, it works. But there were 2 ones:

I don’t know which is which. The difference is: the left one is OK, but I should change my display setting from 200% to 100%.

Since I tried several times, open-close-open-close…, every time, it was OK, so I hope maybe it will run well.

Just see.

The first thing I did this morning was testing Fritzing, when I typed in CLI, the same with past, it couldn’t run. When I click the left ICON in “Show Applications” (the same with “Start Menu” in Windows), it was OK.

While your best solution is still to download the tar file from the download site (which has a proper parts library pre installed). If you want to use apt-get, I’d check if there is a fritzing-parts install. Some of the installers (as mentioned earlier) do not make parts a dependency and thus do not load the parts. This causes errors such as you are seeing. If that is the case you need a command like “sudo apt-get install fritzing fritzing-parts” (assuming the parts are called fritzing-part) to load both packages. This may be a bit late as my link died before I could post this earlier.


I have drawn a whole day for several drawings till now today. It was OK, so I think maybe I found the solution.

Thank you and uMerlin, I just visited his profile, I want to add he(or she) to my account as one of my leader, but there was no ways, so …

The forum adds the tag when some criteria is met (I don’t know exactly what though) …


That particular badge is specifically assigned “by staff”. See leader badge

I spun up a ubuntu 18.04 vm to test some combinations for installing and running Fritzing. Here is a summary.

apt-get install fritzing does not install a parts library. What worked best for me was:

sudo apt-get install fritzing fritzing-parts qtwayland5

With that, run from activities (the GUI) worked fine. Attempting to run from the command line tries to open the parts library in the home folder. Which is where those messages about device not open and the …/bins/ files come from. With that installation (version 0.9.3b), to run from the command line use:

fritzing --parts "/usr/share/fritzing/parts"

The parts library is read only, and can not be updated (without using system level privileges).

Another installation, to get version 0.9.4b, is to use flatpak

apt-get install flatpak
flatpak remote-add --user --if-not-exists flathub
flatpak install --user flathub org.fritzing.Fritzing

That also works to directly run from the desktop interface. To run from the command line, use:

flatpak run org.fritzing.Fritzing

Again the parts library is read only. To get an updatable parts library (for either version), it can be downloaded and stored locally, then specified only from the command line when Fritzing is started. Both the 0.9.3b and 0.9.4b versions accept a command line argument to point to the parts library. The standard GUI environment does not. I believe that a desktop icon can be created that would provided the needed parts library path, but that is outside my knowledge.

If downloading a parts library, do NOT put it in $HOME/bins. Do NOT put it in $HOME/Documents/Fritzing. Put it someplace like $HOME/Documents/data, so the parts library path becomes something like “$HOME/Documents/data/fritzing-parts”.

What goes in $HOME/Documents/Fritzing (/bins and /parts) is only the custom parts. Those loaded from .fzpz files. It is also the default location to save sketch files.

To avoid the need to enter long lines each time when specifying parts library paths, the needed command can be put in a 2 line (executable) script file. If that is stored somewhere in the standard search path, it can be run by just entering the file name. Otherwise the full path to the file needs to be used. For example:

#! /bin/sh
flatpak run org.fritzing.Fritzing --parts "$HOME/Documents/data/fritzing-parts"

Those installations are both different than what would be needed with the file downloaded from the Fritzing website. That version has instruction provided there, and should end up with a parts library that can be found and updated, when started from either the GUI or the command line, without needing any extra arguments.

Excellent practices, I need to draw some circuits first, then come back for testing these solutions.