Failed upload with exit code -1, 0

I am a new user and trying to upload a sketch (Blink) to my Arduino Uno.
I have selected the Arduino on Com 4.
I have selected Edit -Preferences - Code View and pasted in the shortcut to my Arduino IDE.
However when I try to upload the sketch I get

Running C:/Users/Andre/AppData/Local/Programs/Arduino IDE/Arduino IDE.exe --board arduino:avr:uno --port \.\COM4 --upload C:\Users\Andre\AppData\Roaming\Fritzing\fzz\38c15ffdcec4171057cf085efb9638c6\Blink_TMP\Blink_TMP.ino

Upload failed with exit code -1, 0

I have tried the same upload through my Arduino IDE which was successful.

Am I missing something in the Fritzing setup?

A search for code upload in the forum search box turns up a number of hits. I believe it is still true that code upload doesn’t work correctly on the Arduino IDE (but I may be wrong.)


Thanks for that Peter, however I suspect the example you have given may be a separate issue. The stk500 is associated with a serial comms error. I experienced this recently when using a clone NANO with Arduino IDE where the processor had to be set to Bootloader OLD to get by the stk500 issue.
I have tried the Fritzing software with both an Arduino Uno and an Elegoo NANO but the software will not upload to either model.
It would be good to get a definitive answer on whether the software is yet compatible to upload to an Arduino.


Thanks to everyone who replied, and for reference I have rolled back my version of Arduino IDE to version 1.8.19 after having a discussion on an Arduino beginners FB group and the upload now works from Fritzing.

It would be good to know what version doesn’t work, as a change to Fritzing to keep upload working may be in order (it didn’t used to be an issue because development had stopped, but development has started again …)


Apologies I thought I had mentioned the version in my first message. It failed on version 2.0.3 (the latest version) of Arduino IDE and I have changed it for version 1.8.19 which is working fine. Both versions are Windows 64bit