Creating parts with movable schematic elements

Ah yes! you made it work! This is awesome stuff Steel Goose! Thank you very kindly! :smiley:

Here’s a TL072 that I got to work with movable parts! :sunglasses:

TL072.fzpz (13.3 KB)

1 Like

Next for the LM13700 :frowning: :stuck_out_tongue: :smiley:

Here’s what I’ve been using as a schematic in my dual OTA

As you can see, pin 11 (V++) appears twice (as intended) but my problem is that I’d need both of these to act as pins for ideal use. It works fine now but the schematic would be better if I could make connections to both of these schematic points.

First I’ve got to make its jiggly bits… :smiley:

Tips on making parts.
I kept finding ‘connector0terminal’ in the svg with nothing on the layer… what a noodle baker! I found a thread by Steelgoose on here about making those terminals into any kind of shape you want and naming it accordingly within the svg file.
Sorry no link handy… but it seems to be crucial that there is an element in the SVG with the corresponding ‘connector#terminal’ for parts that use subparts.
I noobishly made a work around for this before (needing to make movable parts and…) finding the correct way. I would just make any old svg file that looked right, witout concern for the naming convention, and do all the connections in Fritzing as this seemed easier to me but putting the time into the SVG first saves time in the long run. If you name all the connectors (Terminals and Pins) in the SVG first then you have nothing to do in Fritzing except load the image; the naming convention from the SVG file makes automatic connections and pin assignments when loaded into FZ! Very cool indeed.

Anywayz, as (half)promised,here is the LM13700 in all it’s movableness! :smiley:
LM13700Noodle.fzpz (9.0 KB)

Thanks again for all of your help on these parts Steelgoose and PeterVanEpp.

I thought I had this all figured out… :smiley:
I can’t get this hex inverter to work. :blush:
HEF4069.fzpz (6.7 KB)
Is there a limit to the number of subparts?

Hi NoodleDriver,

Not that I know of, there shouldn’t be a limit number of subparts.

Your subparts are mislabeled in the schematic.svg; i.e. In your .fzp the subpart is labeled “id="subpart5"”. In your schematic.svg your subpart is labeled “id="subpart5_1_”. The underscore 1 underscore could have been generated automatically if you had duplicate ID names.

You can just open the schematic.svg in a text/xml edition and delete the underscore 1 underscore from the three layer IDs and re-save.

1 Like

Hi Steelgoose,
Thanks a million, once again.
I didn’t realise that svg’s were readable! :smiley: I was somehow sure that they’d be gobbledygook!
Very nice!
So, I edited the svg file as you mentioned and it worked like a charm!
I suspect this is a tiny bug as Fritzing definitely changed my layer names.
Here is the corrected version:
HEF4069v1.fzpz (8.9 KB)

No, it is not a tiny bug… You can’t have duplicate IDs. When you have duplicates, the suffix will be added in sequential numbers. I don’t know if it was done in Inkscape or FZ. I didn’t see duplicated ID names so I am not sure what caused it… It might have been something that you previously had done… You could go back and look at your inkscape XML editor and see how it is labeled.

Don’t forget my :heart: (like this post), if you like… I am collecting them, :grinning:

Learn something new everyday… :relaxed:

1 Like

I think the suffix change is probably Fritzing. Experience tells me that Inkscape deals with dups by reverting to the original name of the element (i.e. setting connector0pni on two different rectangles will cause the oldest to go from connector0pin to rect3848) or just as possibly a new name it just made up but not as far as I know via suffixes. As noted I have been bitten by this one in Inkscape …

1 Like

If I remembered right, the suffix was add when I exported the image from CorelDraw as an .svg, when I had duplicated ID name. So I thought I would see if my brain was still working… “no comment please” :slight_smile: and test it out. Below I entered id=“subpart3” three times, you can see how it added the suffix to the last two. Although, I don’t have any idea why NoodleDriver’s file was like that, but I do know CorelDraw does it this way. All programs are different, I am not familiar with Inkscape and FZ has some weird idiosyncrasies…


Computers don’t make mistakes… People do… It just takes computers to really screw things up… :confounded:

1 Like

Transistor Array

CA3046.fzpz (6.6 KB)

CD4066 CMOS Quad Bilateral Switch

CD4066.fzpz (198.8 KB)

Hi Guys,
Wow how did I miss this thread? Sorry I wasn’t around to lend a hand! Welcome to sub-part hell @NoodleDriver! As you have seen already the real acid test with these is creating a couple of real life circuits with them. You quickly learn where the gotchas are. If you have any remaining queries I’d be happy to help.
I am really impressed, you’ve created some awesome parts and so quickly! It tooks me forever just to get the first one working.

Hi sgparry,

Thanks, I’m glad you like the parts!

The first one is always the hardest! This was worth learning. Making simple parts is a lot more clear now.
I still strugle with the PCB layer but luckily, I rarely need to do anything on that layer. Lack of practice most likely.
Anyway, I lost a big file today :frowning:
I finished it last night then decided to rename the folder this morning. DOH!
I can’t, for the life of me, get it to open now and the part I created for this project has vanished from my parts folder.
Luckily, I can open some of the earlier save points that I made along the way so not all is lost :smiley:
I have discovered a new problem with my Fritzing insallation now;
The search tab is missing. I tried resarting the program but no luck there.
So I will now uninstall and reinstall it but first I want to back up my parts on here :smiley:
All of my Multi-parts are here already so the rest are just regular oddball parts.

1P4T Switch.fzpz (5.1 KB)
CA3046.fzpz (6.6 KB)
CA3080.fzpz (5.7 KB)
LT44 Transformer.fzpz (5.7 KB)
MPF102.fzpz (5.5 KB)
OTA.fzpz (9.0 KB)
TL072.fzpz (13.3 KB)
CD4066.fzpz (198.8 KB)
TL074 Quad Opamp (Movable).fzpz (8.9 KB)
Some of these are slightly messy looking but they all work! I have tested all* of these on my own PCB projects…
*I have not tested the 3080 yet TBH but it looks perfect.

edit: The 3080 works like a charm :smiley:
More parts to follow below…

1 Like

Well, the reinstall worked out ok but it did’t restore the parts search for me.
I now have now way to find parts easily.
I should probably start a new thread for this but I thought I would update here anyway.

Are you running windows 10? There seems to be a problem there. This thread has a suggestion (but note you need to save the directories as it will delete all you work!) on how to clear the data directories which may restore it. I’m starting to wonder if a Win10 update has broken something on Win10.

also note Old_Grey’s suggestion on AV perhaps eating files. I assume that search did work for you before something happened (which points at corruption in the temp directories)?


Hi Peter,
Thanks for this!
Yes, the search was working on Win10 for me perfectly until today.
It happened whilst I was trying to recovre that sketch.
I had just used it succesfully then next time I tried it the tab was there but it was broken. I reloaded the program and the tab was gone.
This fix sounds like it could cause even more problems if it corrupts my sketches.
I haven’t tried opening any others yet but I shudder to thinkj there could be problems with devices I have already built! Oh no! I will make do without search for a while :smiley:
Cheers, Kevin.

Possible suggestions:

  • rebuild parts database
    if that does not work try:
  • exit Fritz
  • delete C:\Users\your-user-name\AppData\Roaming\Fritzing\bins\search.fzb; can only be seen when you have all the hide system files turned off and show hidden files turned on.
    Also, you may need to move your latest parts ‘out of the way’, as a flaw in their metadata may be frakking the search.
    You can also try turning on logging from the help menu and see if you can spot the error that is breaking the search.