Api-ms-win-crt-runtime-l1-1-0.dll Fix?

Are there plans to fix the api-ms-win-crt-runtime-l1-1-0.dll issue with version 0.9.3b?


the dll problem depends on your platform. i’m still using xp so i had to forgo version 93b and install the previous 92b. the dll you refer to is apparently part of the 2015 C++ IDE package. i can’t install the package, so i can’t have 93b on this machine.
google the file name and you’ll get directions on how to update your software.

mike wax

1 Like

Hi Mike,

Thank you for taking the time to respond. I’ve seen the directions for addressing the api-ms-win-crt-runtime-l1-1-0.dll issue. I simply can’t believe that Fritzing continues to burden their users with this. I assume a majority of users are impacted. Fritzing should either eliminate it’s dependency on the api-ms-win-crt-runtime-l1-1-0.dll or incorporate it into the (automated) installation procedure. What percentage of Fritzing users are stuck with the old software due to this issue? It simply doesn’t make sense.


I doubt it’s that many, because 9.3 worked fine for me on one PC with another needing the API but ran fine after that, and there is only a handful of people posting the problem.

After the API link was posted a lot of people got it going.

Unfortunately that also hit me.
I’m with you wickedbeernut. It really doesn’t make sense.

I’d encourage everyone who’s been impacted by the api-ms-win-crt-runtime-l1-1-0.dll issue (regardless of whether you successfully resolved the issue or not) to reply to this thread. There seems to be a perception that not many Fritzing users are impacted.


What have you done to fix the problem.

Did the api install?
Did you keep waiting when the thing looked like it wasn’t responding?
What setup do you have?

If you read the posts people post the problem, someone offers a solution, and after that they seam to not post anymore, like it’s fixed.

I did read that W10 has a problem, and that they are working on it.

i did some research and found that the missing dll error seems to be an error for people without
the regular updates from microsoft. sadly there is no update for xp. all other users just need the update
from this link: (or just update the system via windows-updates)

anyway, i have a version of fritzing build with visual studio 2013 and it works at least in a fresh win7 64bit sandbox without any updates. so i assume it will work on winxp too.
please download this build and try if it works. if so, we can offer that, as a “xp-download” via the fritzing website.

p.s.: it is not recommenced to use 0.9.2b because it has the really hard “jumping wire” bug and an old parts-mechanism.

1 Like

I also have this issue… Windows 7 Enterprise, Service Pack 1.

Found solution here:


Same issue over here…

Thanks for that, but the link is Bad Request Error 400. Now what can we try?

UPDATE: I think I found a fix: http://www.microsoft.com/en-us/download/details.aspx?id=48145

I don’t know how well it will run, as I haven’t designed anything on it yet, but at least Fritzing 0.9.3b opens without the error on XP32! Please post if installing the Microsoft Visual C++ Redistributable for Visual Studio 2015 works for you or not.

Developers: My better machine is actually XP for business programs (other OS on little laptops), and I don’t appreciate being told I should add to Microsoft’s wallet when other systems are treated to reasonable attention. Many biz systems still require XP, and developers unwittingly bash us for doing what we must to make things work. This sux for us. The same garbage when developers were bailing from Win98 and systems were not allowing it. I thought you would have learned from that. Thank you for Fritzing, and while I don’t ask for or expect sympathy for our plight; please stop beating people up or treating them less than respectfully when you don’t understand. Thank you.

Instalar o windows 7 SP1 e depois o runtime visual c++ 2015.

I’m still running XP too and had same prob. After reading through the replies tried V.92b, Now program is running with no probs. :slight_smile:

I tried 9.2b on my XP Service Pack 3 machine and found that I could not used the wire in schematic.

I downloaded Microsoft Visual C++ 32 bit which gave me vc_redist.x86.exe

After I ran that 9.3b worked fine.

This is the 2nd machine I have loaded fritzing onto the other has Win 10 and it gave me all sorts of grief before I could load that as well.

I agree with the previous posters that there are still heaps of people using XP, I know in my case this is what I used for my hobby as the family won’t touch it because it is old.


This will solve ur problems.

Same problem here.
Win 8.1. Pro
I just don’t get it why after such a long time it is not corrected.
There must be many people having this problem and not all of them can spot this forum, the specific discussion and send their comments!
I even had to log in, something that most people or students will avoid to do.

If the whole thing is just a missing dll, please add it.

You are using a Beta software (has not reached its first release yet) and it has not had a new beta release in a year and a half. Also it is open source so if you feel it is so bad please feel free to submit a patch on github for the problem. Beyond that finding the answer to a problem is a good skill to have and if fixing a dll is too much work for someone they are unlikely to be happy making circuits as there is a continuous need to research data that will take longer than finding an answer that is spelled out for you in a pinned thread on a forum.

It is the entire c runtime library that is missing not just one dll. There is apparently a licensing issue as well (you need a Microsoft license to redistribute the c runtime library) . The error appears to be issued by Windows not Fritizing and I so far have not found anything on the net that tells me how Fritzing would detect that the run time library is missing before calling it to issue a better error message than is currently done. Lots of information on how to download the library from Microsoft (and warnings about licensing) but no detection code that I have found. If someone knows of a way I’d appreciate a pointer.


In response to "sublimeartistry"
Not all of us are programmers and if we could correct the problems we would have done it already.
I got the impression from previous posts that is was only a missing dll. Some even suggested download links.
This is why I was wondering why you do not add it.
However, even though I downloaded and installed it (not only the dll but the complete distributable) but still it is not working, so this means that it is not as simple as this.

All in all, I have the feeling that many people are affected by this and i anyone could help it would be great to do so.
Sorry if i offended someone. Didn’t mean to do so!