Api-ms-win-crt-runtime-l1-1-0.dll Fix?

In response to "sublimeartistry"
Not all of us are programmers and if we could correct the problems we would have done it already.
I got the impression from previous posts that is was only a missing dll. Some even suggested download links.
This is why I was wondering why you do not add it.
However, even though I downloaded and installed it (not only the dll but the complete distributable) but still it is not working, so this means that it is not as simple as this.

All in all, I have the feeling that many people are affected by this and i anyone could help it would be great to do so.
Sorry if i offended someone. Didn’t mean to do so!

The runtime download is certainly a requirement, that doesn’t mean that more things can go wrong though. What isn’t working now? The most common problem after the runtime dll is not waiting for the parts update to finish and/or closing the program before it finishes (a progress bar for that download is one of the projects on my list of things to fix). It that happens you need to delete the user directories to clear the corruption. There are a number of posts on how to do that or I can provide instructions.


If the runtime is a requirement, please provide a link or instructions to find the correct version.
I already downloaded one from somewhere, installed it, rebooted and still the same problem and the same message.

I think (because I’ve always had multiple copies of the C runtimes on my machine and thus never seen the problem) that any recent copy of the runtime libs should work. There are a couple of links back in this thread and even more if you type dll in to the forum search bar.


Exactly those links I used (f.e. https://www.smartftp.com/support/kb/the-program-cant-start-because-api-ms-win-crt-runtime-l1-1-0dll-is-missing-f2702.html ) but still no solution to the problem.

OK lets try something different. On my Win 7 pro box in

Control Panel\Programs\Programs and Features

I have

Microsoft Visual C++ 2013 Redistributable (x64)-12.0.21005
Microsoft Visual C++ 2015 Redistributable (x64)-14.0.24215

and I believe it is using one or the other of those (in theory the 2015 one I think). One or the other of these was supposed to be loaded (and was in my case) by Windows Update. There were however problems and many systems didn’t get the update. If you don’t have one or the other of those showing in the programs window, I’d suggest checking if Windows update is running correctly (one of the patches broke it back in November on this system and I had to delete the update directory to make update work again). An easy test for that is open Windows Update from the start menu and try and check for updates. If it says it can’t then you likely have the bad patch and need to fix it to get updates again. You may also try downloading the libraries from Microsoft.
I used “win 7 download the c run time libraries” (because I have Win7) and the first couple of hits are Microsoft who is the official source of the libraries. I believe they vary by Windows version as well so substitute your version of Windows in there (which is why we can say one download fixes all, because it doesn’t). Windows 10 when it first came out had a lot of troubles with this, but I haven’t seen a lot of complaints lately.


This is what I have installed…
I guess the last one (which was installed on 27/01/2018) is the one I installed cause of Fritzing…
As far as I know it is the latest version which I downloaded from Microsoft.

With this you still get the missing dll error? If so that would indicate you either need the 2015 version for some reason, although from what I have read the 2017 version is supposed to be compatible or it isn’t complaining about the run time library. Can you post the exact error message you are getting with the dll name it is missing please? Its possible that it isn’t complaining about the runtime libaries but something else and we are chasing the wrong problem here.


Here it is… I reproduced the error on top of our messages to see it is not something old…

Well this is a new one. Unfortunatly I don’t have an answer. I just built a development disk with Qt and Visual Studio which is using the 2017 Redistibutable. I just deleted the 2005 and 2013 versions to make sure it wasn’t using one of those, and Fritzing still starts fine for me using the 2017 Redistributables. You might try deleting all the Fritzing files (assuming you don’t have any sketches or parts that you want to keep) and see if a reinstall helps. As well as the files that loaded from the zip file there are two user directories that don’t get updated if the program is reinstalled (although that doesn’t usually cause this particular problem):

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketchs during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you wan to keep something in them.

If that works, the first launch of Fritzing will appear to hang (as it updates the parts database from github). Just wait until it completes, it will eventually tell you there are new parts available, as interrupting it is what causes you to need to delete the two files above usually.


A new one? But -I guess- it is exactly the same problems that others were having in the beginning of this discussion, and this is why I posted here!
I do not see any difference… Please have a look at the title of the discussion:

“Api-ms-win-crt-runtime-l1-1-0.dll Fix?”

I have already reinstalled the program without any success.
There is no problem with lode files since I have NEVER used it (in this computer) simply cause it never run!
I guess there is no hope…

It is a new one in that loading the runtime libs hasn’t fixed the problem. In all previous cases I know of (unless some people just gave up, which is possible) loading the runtime libraries has fixed this issue. With Windows 10 that often took a number of tries to get it right back in the days of one of the early patches, but eventually it fixed it. As I said I don’t have any more suggestions, it runs on lots of Windows machines (I have 5 of various flavors) on any of the supported OSes (I don’t believe it will run on XP because of runtime library issues but I haven’t tried either). Something appears to be odd about your machine is about as much as I can say.



You can fix this error using the methods provided in the guide here: https://www.intenseclick.com/api-ms-win-crt-runtime-l1-1-0-dll-is-missing-error/


Re-register the DLL file and check for the problems.

I just published a pre-release. I don’t have the means to support XP or 32 bit versions. So currently, four builds are done: Linux 64 bit (recent Linux distributions >= 2016 should be good), MacOS High Sierra and Maverik, Windows 10 , 64 bit.
The Windows 10 version might or might not run on older versions, I don’t have the resources to test it or to maintain an older windows toolchain. Some problems might be easy to fix, so it would help if you try it, and leave me a note how it worked (create a new thread or issue on github). Look for the latest pre releases on github, e.g.

Once the release is finished, it will also be published via github first.

Greetings, Kjell

At a fairly brief test (a sketch and a part) the Win10 64 version appears to work fine on Win 7 Pro. The parts update is working again (the new version of libgit2 fixes that.) For others that want to try this, note that it is using the production app data directory, so before trying this make a backup copy of


(where “user” in the above is your Windows user name) so you have a backup copy (which you should anyway) of your added parts in case of problems with the new version. I have switched to running the dev version as my default and would encourage any one else that can to do the same. It needs wide testing to flush out bugs before a release. I’d actually like to see the suggestion I made at the bottom of the roadmap

where the dev version uses a different documents directory, but that may be difficult to implement. In any case great work, one step closer to a new release!


Could I try a repair install which will reinstall Windows fall update while keeping my personal files & all programs? I have the same issue with api-ms-win-crt-runtime-l1-1-0.dll

I’d suggest backing up your entire system before doing anything about this as dll changes may break your system. That said can you post the exact error message you are getting and tell us which Windows and Fritzing version you are running? I’d suggest trying the latest Fritzing version (0.9.4) which was released a couple of months ago, although I don’t think it is likely to fix this problem (which is a Windows issue rather than Fritzing.) It may be that just loading the C runtime library files (which is relatively safe) will fix the problem, the issue described here is unusual and with Windows 10 one of the updates fixed most of the problems.


Thanks for your reply back.

The error I get is “Program cant start because api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer try reinstalling to fix this problem” I’ve tried re-installing by following this guide https://techloris.com/api-ms-win-crt-runtime-l1-1-0-dll/ first I thought it probably because of visual C++ but after repairing visual 2015 it still doesn’t work.

Any idea?