Windows 7 install failure

I downloaded the Win64 version, and tried to follow the instructions for installing it. I unzipped it into a directory in Program Files, called Fritzing. But when I double-clicked fritzing.exe, I got the message

The program can’t start because
api-ms-win-crt-runtime-I1-1-0.dll is missing from your computer
Try reinstalling the program to fix this problem.

Note that if the file is missing, the file is missing, and “re-installing” the suite of files is not going to magically produce this file if it is not in the original file distribution. I do not recognize this file as an expected Microsoft DLL, although parts of the name suggest it might be the Windows C Runtime.

So what do I do now?

One of my Win7 installed right of the bat, but the other had to have the MS api program installed.

Plenty of posts about it.

I think this is it.

Wasn’t successful. The install of this package on Win7 hung, and when I quit out of it, the error log showed that certain modules had failed to install.

It would have been nice if the download actually contained everything necessary to create a running installation.

Fritzing has proven to not be terribly useful to me, because I can’t get it to run.

There is no progress bar on the download, so it can look like it’s hung. Just let it sit for 15min.

Thanks Old_Grey for the tip. 2999226 appears to have worked for me.

However, supuflounder, like you, I have recently had the same problems loading Windows Updates. I think Microsoft might be making some changes in the Windows Update procedure.

After trying a number of suggested fixes I found online, this one finally worked for me. Once I used this procedure for fixing Windows Updates, I was able to manually install the 2999226 update successfully. That allowed Fritzing to install properly.


@DonpK Thank you! In fact I had the same problem but couldn’t find the solution. Thanks for the tip, worked for me :slight_smile:

I gave up after 30 minutes. I hadn’t mentioned the time constant before.