VCRUNTIME140_1.dll was not found

When starting for the first time, it gives an error message:

Code execution cannot continue because VCRUNTIME140_1.dll was not found. this problem can be solved by reinstalling the program.

I have reinstalled the program twice and the problem persists.

Greetings.

Toni350

Hello Toni350, welcome to the forum.

Fritzing comes with the VCRUNTIME140_1.dll, but maybe it was not allowed to install it.

To be more precise: The file VCRUNTIME140_1.dll is part of the Microsoft Visual C++ Redistributable for Visual Studio. Fritzing 0.9.6 ships with an installer that detects if that library is missing and will try to install it.

We have checked that this works on Windows XP, Windows 7, Windows 8, and Windows 10, all 64 Bit.

If any required libraries are outdated or missing, the Fritzing installer will show a dialog to ask about installing them.

This is how the dialog looks on Windows 8:
image

We recommend letting it install the file, but you can also try to go without it.
If you do not accept, the installer will show a further warning and allow you to continue. This may work if the file is just outdated. However, if the file is missing, you will see an error similar to what you have described.

If you do not trust the Fritzing installation procedure, you can also download and install the files directly from Microsoft.
To do this, select the vc_redist.x64.exe from this page: https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0

Please always go via the Microsoft page, do not download the DLLs from random internet sites.

Besides simply not allowing the installation, what else might have gone wrong?
a) Some Antivirus enthusiastically prevented it without telling you
b) The files are long installed, but the DLL has been damaged. In that case, it looks like it is there, but it is not.
The Fritzing installer can not compensate for those cases, but installing the dlls via the Microsoft redistributable installer (see link above) should resolve this.

Hello KjellM, thanks for the support, after installing vc_redist.x64.exe, it worked fine.
All the best.
Toni350