Uncopleted Gerber files for Aisler

Hi folks, I’m using a custom board file, this is the result when I go to see the uploaded file on the Aisler site.

Looking with Gerbview the file is broken, incomplete. The figure of the board and of the inside hole appears open on one side. The same side for both the shape, the top side, in both the solutions I tried: horizontal and vertical.
I checked the SVG files using the etchable SVG files and all appear right
this is also evident on the Aisler website
AISLER image.
As far as I could understand on the forum, this belongs to the Fritzing Gerber compiler.
Does Anyone have ideas or solutions about it?
Otherwise please shell you take this like information for the next program upgrading.
I would like the forum administrator to be kind to me if I have not respected the forum rules, but I care a lot about this project and Fritzing I feel it like a warm sweater in winter.
many thanks.

I don’t really know, but if you uploaded the .fzz sketch with the 7th button in the toolbar maybe someone can look at it, ie, it would help people better understand what is going on.

Thank you very much, old gray, it could be that Aisler’s staff could suggest a patch on my file, but the problem arose in Fritzing’s Gerber compiler. This we can see by taking a look at the Gerber file on the nude board. As I have already written trying several solutions, the lost line is the upper one of the table and the left one of the internal rectangular hole.
gerber boardoutline

All I can think of is the PCB svg isn’t perfect, hence the upload, but you’ll have to wait for an expert because I don’t know much about that - I think Opera Night is the cutout expert. As for the outline, is all of the drawing inside the svg resize border.

It is likely a problem with the gerber export logic in Fritzing, but there is probably a fix that can be done outside. Seen before, the gerber export does not close svg path elements in pcb shape files. That is, it does not draw the last edge. The work around is to explicitly add the last point as a duplicate of the first point of each (supposed to be) closed shape.

Hi at All, thanks to your help, I tried again to make my custom board and as I’ve seen on the Aisler browser it’s ok.
probably the problem was done because, in the previous editions, I had some problems using the InkScape tools and I used my eyes to center the two layers with the Inkscape board layers.
With the right use of Inkscape, I made a correct version and I did solve the problem.
Thanks again. My hope is that my low level (is another way to say stupidity) can help other beginners.
thanks again

As long as I can’t find a way to close this topic, I write that this problem is SOLVED