Unable to run fritzing


I’ve tried more than 10 times to download, unzip, install and run Fritzing without success. I have the latest issue and have downloaded the appropriate Windows 64 bit version but it freezes each time i open the programme. I just get an error message “Fritzing not responding”.

What am I doing wrong? Is there a bug that i don’t know about.

I’m getting frustrated now, especially since I made a donation!

Please help me get started.


When you open it for the first time you have to wait 15min for parts to be downloaded, unfortunately there is no progress bar so you don’t know it’s actually still running.

In order for the parts update to take place you also need a network connection (as it is trying to access github to update the parts database). If you don’t have a network connection it might hang as you describe …


I’ve tried waiting for 15min after first opening the application. I also have a network connection. It still doesn’t work. I cannot get Fritzing to run. There must be a bug in the download somewhere. It just doesn’t work for me, which is disappointing since I made a donation. I either need to get it to work or get my money back.

Your anti virus might be striping files. Turn it off and try again.

One other thing you might try is to delete the directories

c:/Users/win_user_name/AppData/Fritzting and
c:/Users/win_user_name/My Documents/Fritzing
(note AppData is a hidden directory so you need to enable show hidden directories in explorer in order to access it) Fritzing uses these 2 directories for tmp and your parts files but does not delete or over write them when you do the unzip, so if something has gotten corrupted in them that may be your problem. If the directories aren’t present Fritzing will recreate them. Otherwise the software works for lots of other people so there has to be something going on with your system as this isn’t one of the common problems (such as missing C runtime DLLs) that have occurred before. Good luck!

I was able to help my Dad solve this problem by using SysInternals perfmon to see what the process was doing. Thanks to the earlier posts about the initial startup calling out to github I could see the process was constantly searching the system PATH for git itself. It somehow copes without having git installed on the machine but progresses very slowly. By starting again, clearing out the folders mentioned but this time installing git before hand, it completes the update very quickly (less than 1-2 mins) and the program starts up.

N.B this was on Windows, I’m guessing it may not impact other OSs that normally come installed with git i.e OSX or perhaps it’s just a case that people are using git for other projects so there’s no impact.

Whilst I’m here, is this app itself hosted on github? Would happily try and add a progress bar or at least some logging.


Thanks for the update! Yes the source is on github in https://github.com/fritzing/fritzing-app. As far as I know I don’t have git installed on Windows and while it takes some time, the update does occur successfully, I suspect there was something corrupted in one of the Fritzing directories that was causing the problems. Good to know that it got fixed as it tells us what to suggest for other folks in future.