Unable to check for and update new parts

Hi, I’m trying to install 0.9.3b on my Ubuntu 16.04 system. When Fritzing starts, I get an error message about “Cannot find parts”, so, once Fritzing starts, I try Help->Check for updates, which gives me the error message:

Fritzing is unable to check for and update new parts. If you want this functionality, please enable write permission on this folder: /usr/share/fritzing/fritzing-parts.

The permissions/ownershihp on the folder is: drwxrwxrwx root users

I also made sure ‘rw’ was recursively set for both owner and group on all subdirectories and all fzp files. Still no go.

Thanks in advance for any hints / tips with this!!

Check permissions on the path above you (i.e. /usr, /usr/share /usr/share/fritzing as if any of those aren’t writable by your user id fritzing won’t be able to write.

Open a shell using the SAME user you are running the IDE with and try to do a cd /usr/share/fritzing/fritzing-parts
If you get a permission denied error, check the permissions of each directory, sometimes there is a ‘x’ permission missing (x is execute permission for files, but it’s search permission for directories).

So
cd /usr (should work in any case)
cd share
cd fritzing
cd fritzing-parts

I any of those fails you’ll have to add search permissions for your user, do that with “sudo chmod o+x [dir_name]”

Ocsav, thanks for the reply, but, alas, no go. I can cd to all directories from /usr to /usr/share/fritzing/fritzing-parts. If fact, that was one of the first steps I verified, but I just did it again to be certain.

Also tried chmod u+s Fritzing for the executable: /usr/share/fritzing/Fritzing Again, no go.

At this point, I’m giving up on installing in /usr/share and am going to drop back to installing in and running from a local directory.

Did you actually install the parts and data?

cfranklin@cfranklin-Latitude-D630:~$ sudo apt search fritzing
[sudo] password for cfranklin:
Sorting… Done
Full Text Search… Done
fritzing/zesty,now 0.9.3b+dfsg-4 amd64 [residual-config]
Easy-to-use electronic design software

fritzing-data/zesty,zesty,now 0.9.3b+dfsg-4 all [installed,auto-removable]
Easy-to-use electronic design software (data files)

fritzing-parts/zesty,zesty 0.9.3b-1 all
Easy-to-use electronic design software (parts files)

cfranklin@cfranklin-Latitude-D630:~$ sudo apt-get install fritzing fritzing-data fritzing-parts
Reading package lists… Done
Building dependency tree
Reading state information… Done
fritzing-data is already the newest version (0.9.3b+dfsg-4).
fritzing-data set to manually installed.
The following NEW packages will be installed:
fritzing fritzing-parts
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 9,513 kB/13.1 MB of archives.
After this operation, 151 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://us.archive.ubuntu.com/ubuntu zesty/universe amd64 fritzing-parts all 0.9.3b-1 [9,513 kB]
Fetched 9,513 kB in 5s (1,840 kB/s)
Selecting previously unselected package fritzing.
(Reading database … 269382 files and directories currently installed.)
Preparing to unpack …/fritzing_0.9.3b+dfsg-4_amd64.deb …
Unpacking fritzing (0.9.3b+dfsg-4) …
Selecting previously unselected package fritzing-parts.
Preparing to unpack …/fritzing-parts_0.9.3b-1_all.deb …
Unpacking fritzing-parts (0.9.3b-1) …
Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for desktop-file-utils (0.23-1ubuntu2) …
Setting up fritzing (0.9.3b+dfsg-4) …
Setting up fritzing-parts (0.9.3b-1) …
Processing triggers for man-db (2.7.6.1-2) …
Processing triggers for gnome-menus (3.13.3-6ubuntu5) …
cfranklin@cfranklin-Latitude-D630:~$

I was having issues as well, until I had seen the parts and data packages. The built in GUI software manager doesn’t show these.