Trying to figure out why a PCB logo is not generated

Hi all.
I have spent the last 2 days trying to figure out why a PCB logo is loading happily on Fritzing is not shown when either PDF or Gerber files are generated. I checked the file with various tools for any errors/notifications that I might have skipped, but the file/image seems to be OK.

Using the same file as PNG doesn’t produce good results and I would like to avoid it.

Anyone has an idea what I should be looking for?
I have attached the image for reference.


You probably need one small change.

<g inkscape:label="Layer 1" inkscape:groupmode="layer" id="layer1" transform="translate(-94.277575,-70.687945)">

That id="layer1" needs to be (probably) id="silkscreen". In general, Fritzing will display most content from images, but it will not export to svg or gerber any graphics that is not in one of the layers that Fritzing explicitly works with. The main ones are breadboard, schematic, silkscreen, silkscreen0, copper1, copper0, board, boardoutline depending on the context. Each of those is used in specific svg files. Some information can be found in the Part File Format wiki article.

Hey @microMerlin, thanks for your answer.

I did a quick test right now changing the layer ID. It loads fine on the Fritzing editor but doesn’t show up on the generated PDF files. It’s weird because I don’t get any complaints from Fritzing while loading the logo image.

I also managed to use a different SVG image which worked fine:


That second svg file does not have any sort of layer (group with an id value). So maybe the place you are using the file works with out the. To get rid of it using inkscale, select all, then ungroup.

If you provide more details about how you are loading the image into Fritzing I might be able to reproduce the problem, and try things to see what is needed to get it to work. What part of Fritzing are you working with? Main or part editor? Specific view? What menu option to load the file?

Hi @microMerlin

I tried again without the group this time. I still get the same behavior. I can load and see the image on the PCB but it’s not exported to PDFs or Gerbers.

I work on the Main Fritzing at the PCB view. I use the ‘Silkscreen Image’ tool to load the SVG file.

Looks like I need more information. What operating system and version of Frtizting are you working with? On my system, Linux Fedora 33, Fritzing 0.9.4, the first car logo loaded correctly using silkscreen image, and I was able to export it (and view the result) as svg, pdf, and gerber. Here is the svg export from my test file.


Here is the pdf, renamed to fzz so that the forum will let me upload it. Just rename back to pdf after download to view it.
test.fzz (107.8 KB)
I could zip and upload the gerber as well, but it looks basically the same in gerbv

In case it is a problem with the Fritzing sketch document, here is the sketch file I create the exports from. If you can export from that using your environment, it would seem to be a problem with your document. If not, then something different in your environment.
test2.fzz (7.8 KB)

I’m using the 0.9.6 version on Linux Ubuntu 20.04. Using this version I tried exporting your project but I still got no silkscreen image on both the PDF or the Gerber files.

I noticed that you are using an older version, so I made a quick test using version 0.9.4 and everything worked as it should.

Maybe this qualifies for a bug report but I’m not sure.
I will probably stick with the older version a little bit more.

Thank you for your help microMerlin!

If it works in 0.9.4, it is probably a bug. Please, report it in GitHub.