Trying to create a prototype part with a "breadboard" element

I am trying to create a part that is a prototype board that contains a “breadboard” element. I just want the schematic to contain the signals for how I connect to the board, but I end up with 140 unconnected connectors. How do I deal with a load of connectors that I don’t want in the schematic. My current attempt is at

Looking at other prototype parts they have all the pads with holes in the breadboard and only the pads that correspond with the schematic in the PCB. The trouble is that if I do that I don’t see a way to do the internal connections. Seems like a catch22. Maybe what I would like is not supported by Fritzing

Looking at other similar parts I would seem to need two copper layers and the current parts editor does not support. But judging by the messages a previous parts editor must have supported copper0 and copper1. When will we see an updated parts editor?

I don’t know if this will help, but I have seen parts with “copper0”, and another group inside that that is “copper1”

Thanks, but as I said the current parts editor does not support two copper layers. If I save the PCB svg from a existing part that has a copper0 and copper1 layer and then load the svg back into a new part Fritzing barf’s saying not supported. Obviously some time in the past it did support two copper layers but not with current parts editor :frowning:

What Old_Grey was saying; Fritzing no longer supports copper0 and copper1 as separate groups. Many similar parts were developed for the earlier version of Fritzing and still have the svg with the early format (separate copper0 and copper1 groups) with there own set of identical elements. This format will not work in the New Part Editor.

In the New Part Editor, you only need one set of elements embedded inside of copper0 which is embedded inside of copper1, or vice verse. In other words, copper1 and copper2 are sharing the same set of elements. For more information, check out the xml block in Section: Loading new images, in the Blog Post: “New Parts Editor released” at: :smiley:

Well grouping one copper layer inside another does avoid the barfing about two copper layers, but I still cannot see how to achieve a “breadboard” type of part.
Okay my part has a number of connections in the schematic okay everything is fine about that. But I need to have other connections that the user can use that are not part of the schematic and also need to be connected together. If you look at the svg file I need the horizontal pads to be connecfed and only pads in the rectangular boxes in the bottom part ( Mikrobus ) to be in the schematic. I tried just for an experiment but when I try and use the top left connectors they are not connected to their horizontal neighbours

Ruff, Ruff, :relaxed: Well Keith, here it goes, see if this will help… Both of your issues need to be resoled in the .fzp file: to connecf :confused: (link) the pads in the first row (connector0, 1, 2, and 3), check out, bus id=“internal2”, nodeMembers… Issue 2: to eliminate pins/terminals from the schematic view also needs to be redefined in the .fzp; in the connector block, schematicView, “remove schematic from the layer”, just leave it blank (layer=""). All unnecessary pins can be removed from the schematic drawing and only the Mikrobus will be displayed… “correctly”. That is about 90 some odd pins that need to be redefined. :grin: Fritzing then needs to be closed and opened back up to take effect to examine you results. :joy: I tested all this out and it does work…

The Mikrobus file was a mess… it was a converted eagle file, :smirk:

Hope this helps, Steve

Hi Steve

Thanks for taking the time to help.

Just to check I am chasing the right stick Ruff, Ruff, :grinning: Are you saying I edit the fzp as an xml file and make the changes you are suggesting.

Looking at the file am I to understand that for each connected horizontal line of pads I need
bus id =“internal[x]”>
followed by
nodeMember connectorId=“id of connector”>
for each of the pads.
Followed by bus id =“internal[x+1]”> etc etc

For schematic are you say I change
layer layerId=“schematic”/> to layer layerId=""/>

Or for each of the connectors where it has
p svgId=“connector0pin” layer=“schematic” terminalId=“connector0terminal”/>

I replace with
p svgId=“connector0pin” layer="" terminalId=“connector0terminal”/>

Yes the file was a conversion from Eagle using brd2svg is there a better way without creating from scratch.

And thanks again for your help.

How do you enter xml in this forum each time I start with a less than sign it makes it disappear. There must be some think I can do to identify a code section in a post

Correct, bus id =“internal[x]”> is the connect group and the nodeMembers that are in that group will be connected.

Correct, just delete the word “schematic”, leave everything else as is, svgId and terminalId no longer apply, they can be blank or filled in but they need to be there as a place holder.

If you want to test it; take the 3-pin Header located in SparkFun Connectors, save a copy in My Parts. When saving, name the prefix “A-PIN-TEST” or something easy to find. You don’t need to edit the schematic svg, just open up the fzp, delete the ward schematic for pin2 and save the fzp. Close Fritzing, Open Fritzing and drag “A-PIN-TEST” on to one of the views. In Schematic View only 2 pins are active and you don’t have that crazy red square around everything. All three pins works in both PCB and Breadboard Views. You can go back and delete everything that applies to pin2 in the schematic svg and only pin0 and pin1 will be visible in the Schematic View.

When I opened up Mikrobus, there were 4 copies of everything; duplicate pcb, schematic, and bb files and each file had a duplicate copy. I opened it up in CorelDraw and started tearing it apart. There is a whole lot of crap in those files that don’t need to be there. Every pin in the schematic was made up of 4 rectangles… Apparently the conversion does a lot of weird stuff.

There is another conversion program someone is working on, a command line program from lib files… don’t think it is quite protected yet.

Keith, another issue I notices in the schematic svg; the pins and terminals did not have corresponding numbers. i.e. connector148pin with connector38terminal. although it is probably in the fzp that way. I think I would just isolate the schematic elements that you want to keep, clean it up a little and delete the rest of the file…

Hi Steve I managed to get all the internal connections working but I still get an error when I try and close the part from editing “saying I have 150 connections not set”. Most of the connections now look like
p layer="" svgId=“connector65pin”/>

And if I try and use the part I have a red box covering the schematic

You have 163 pins, your modified version may have a different count…, 15 of the pins belong to the Mikrobus schematic, That means that 148 pins need to disassociated with the schematic Layer Element in the fzp. Which means you have 2 connections unaccounted for… Looking at the Schematic View in the Parts Editor, there are 2 unconnected pins (AN1 and CS1)… that makes 150 unconnected pins. All you need is just 1 unconnected pin in the Schematic View that had not been disassociated with the schematic layer in the fzp and you will get the red halo box. Actually, with 150 unconnected pins, it is really red…

Keith, I opened up the schematic in CorelDraw, “AN1 and CS1” does not have the element “connector#pin”. These two pins contain 5 rectangles and 1 line. The rest of the pins are contain 6 rectangles and a line. The schematic layer for these pins in the fzp do not contain the element “terminlId” (connector#terminal), which is supposed to be one of the rectangles. Without the connector#terminal the terminal point will be in middle on the connector#pin instead of the end. Although, you can manually set the terminal point in the Schematic View.

If it were me, I would group each pin in the schematic drawing (rectangles, line, and text) to make it more readable, move the connector#pin number to the line, add a corresponding connector#terminal and delete all the unnecessary rectangles.

Sorry but I am not understanding your explanations. So how do I get rid of the unconnected connections, I thought that was the point of changing “schematic” to “” was to get ride of the unconnected connections, By the way it say 150 in 2 views, The version on my machine is not the same as what you are viewing on github and I have all parts in the schematic with layer=“schematic” allocated to an object in the svg. Re schematic SVG, what should the schematic svg look like for each pin? One rectangle and one line where the line is the element connector#terminal. I am giving up for today as Fritzing is trying my patience far far too much. If I export the schematic as an SVG from the parts editor and load into inkscape nothing displays ARRRRRRRRGGGGGHHHH

I can see you are having just gangs of fun… Not real familiar with Inkscape. I believe that one of these files may have some kind of a scripe that created a carbon copy, not sure what is was but when I loaded into CoreDraw there were duplicate copies. It may think there is another set of pins. Like I said, there is a whole lot of stuff that needs to be cleaned up… Give me day or two and I will see if I can figure out what is causing all the problems. :grin:

Would it help if I uploaded my latest attempts to github?

I got it, works perfect, everything except the through hole on the bb. I am not sure if CorelDraw can handle that.

Perhaps you could export the part and email me a copy keith[at] Not aware of any though hole on bb apart from a slot in my Mikrobus-Cobbler and I already have a working Fritzing part for that.

The green background image in the bb view is a single object combined of 184 objects creating 163 see-through holes. When I imported the bb into CorelDraw it disintegrated. I tried to make a breadboard with a combined object once before and it didn’t work, worked here just fine.

All of the rectangles in the schematic svg were apparently the remanence of imbedded pins/terminals from the brd conversion. About 40 of the 183 pins in the pcb were labeled as pads… changed them all to pins. Changed the pins in the schematic svg from the inside row (136, 140, 144, etc) of the bb/pcb to the outer row (139, 143, 147, etc) to make the inside row female. Added corresponding connector#terminal in both the schematic svg and fzp. Disabled the 148 elements in the fzp, schematic layer. Cleaned up the svg(s) to make it more readable. Fixed a few other things, etc. Not sure if your bb will work on this or not… you can try. Made a few corrections… mostly cleaned it all up.

I want to check all the pins to make sure they work and correspond with the three views… then sent off to you. It was fun… learned a couple things. ~Steve~