Tried to edit IC, now cannot delete it from bin! HELP!

Hi, new here…

So I tried to create an IC from the generic IC. It didn’t work and came out with 8 pins instead of 14 which I thought I had specified. I tried a second time and obviously I am doing something wrong as I created a stuff up again.

I cannot seem to find any way of deleting these parts. What is so hard about supplying a delete button or trash can to drag them into?

I then deleted Fritzing and downloaded it again. I installed it and for some unknown reason, the mistake parts I created are there again! I have searched all over the Mac and cannot find a folder where these may be. I would appreciate any help to delete these deformed parts. Failing that, I guess I am just going to have to live with it, or look for some alternative software. I am not that computer savvy, but from what I experienced so far of Fritzing, it seems quite intuitive. I just wish deleting parts from your bin was more obvious.


Say you wanted to delete this battery holder:

Right-click (control-click) the part you want to delete, and this menu should come up. Then, click the “Remove Part” button.

Then click “Yes”.

Your part should now be deleted.

Thanks for the reply. I have tried what you recommended, however, the Remove Part option is in grey and not selectable.

I am unsure what I originally did, but I have two IC’s labeled LM324 which only have 8 pins. Maybe I renamed some stock part and cannot undo this mistake? Your example shows a part from the MINE category. I am unsure where my IC’s are even located. They show up when I search for LM324 or Generic IC, but I have no idea where I have them stored. Like I said, I tried to delete everything Fritzing from the mac but when I download the software fresh from the Fritzing site, these mistakes keep popping up.

Thanks for your help.

You need to delete your part .fzp. I don’t have a mac, but on a mac it’s at something like ~/.config/fritzing/parts/user/LM324{blah blah blah}.fzp or something with a bunch of number and letters. Delete your LM324{blah blah blah}.fzp.

Open Fritzing back up, you should see a warning box stating, can’t find file. Don’ worry about it, it should automatically delete it from the .fzb and should not show up next time you open Fritzing

Fritzing is not that difficult once you get the hang of it. Just like everything else, it has a learning curve…

Thanks for the reply. I still can’t seem to figure out where this anomaly is hidden, so I’ll have to wait until my son returns and can flush it from the depths of the mac. I can live with a bit of crap. In the mean time I have made progress and I am learning and enjoying using Fritzing. I have never laid out a PCB before - only used stripboard in the past. Perhaps this project is a little ambitious to begin with, however, I am enjoying the process. I’ll post more questions as I come up with things.

Look for parts/user in the locations stated in the list of the bottom post.

Two things on parts . I have deleted quite a parts and their created svg drawings and other stuff after some experimenting. Now when I load in my file to work on it , I get error messages that say they can’t find such and such file anymore. I am pretty sure I have deleted all the parts, but don’t know where to look to make sure.

 Also, as I right click to edit a part such as a transistor ,etc I get an error message that says I can't edit the fpz for it. Looking in that location , there is only something that says "placeholder".

I am in Ubuntu running Fritzing 9.2 using sudo apt-get install .

The current version of Fritzing is 0.9.3b, 9.2 is older (and I think quite different although I have never run it, only 0.9.3b). I’d suggest uninstalling 0.9.2 and installing 0.9.3b via the tar file available on (or via your package manager if they have it, but I think many don’t). 0.9.3.b came out in 2016, so 0.92 is quite old. On 0.9.3b part deletion is a little odd, often the part isn’t fully deleted until you shutdown and restart fritzing (don’t know if that was true of .9.2). The part file format here:

details where the user directories are stored (they don’t get deleted during an install, and sometimes need to be manually cleared). I expect that will be the same on 0.9.2 but am not sure.


Thanks Peter,
I removed 0.92 and many problems along with it .
I can now actually edit existing parts instead of getting an error message.
_When I open my project I no longer get the error message about missing parts, fpz files and so on.

I will now open a new thread message on a strange phenomena on the font sizes loading in incorrectly from inkspace svg I have saved. They come out as huge size in Fritzing’s schematic view, I deleted the original ones and even my newly created fonts were huge.