Start-up Error After Update Fails

The attached error is now being received upon start up.

This was a clean installation of Fritzing. Then I tried to run the “check for updates” and the update failed. Now the error.

I searched the forum, but couldn’t see anything about the update errors.

Running on a Mac Sierra.

Likely database corruption. Assuming you don’t have anything (parts or sketches) that you want to keep (in which case either copy these two directories else where ore rename them), delete directories


(presumably your login id replaces username above). Fritzing should recreate these two directories and update them (correctly this time we hope) from github. These two don’t get deleted during an install, so just reinstalling doesn’t help.


Thanks for the reply Peter. I deleted the two noted directories, restarted Fritzing and was greeted with the same error.

well that’s an unpleasant surprise! I just checked for updates to make sure that a new broken one hadn’t appeared, but Windows reports no new updates. Something must be wrong with your machine’s connection with githun (I recognize a few of those parts as part of an earlier update). Is there an error message when the update dies? You might also try starting the debug log window in help->enable debugging log. although I’ve never seen it return useful information before :slight_smile: . Other than that our only hope is a Mac person that has run in to this before and knows a cure.


It should be said that Frtizing becomes unresponsive during a parts update and your system may ask if you want to force it closed. If this happens you must wait for it to complete. If you close it while updating this will happen every time. So to repeat, delete Fritzing and the hidden files, re-download Fritzing and upon first start up just let do its thing for as long as it takes to complete the update and become responsive.

Thanks for the help @sublimeartistry deleted the files and re-installed the app. Opened the app will let it take a course of action.

Will the app update on its own or does need a push?

On first install it will update itself. It is supposed to check for new parts on every start, but I’ve had cases where clicking help_check for updates finds new parts even after a recent start, so it doesn’t seem to be %100 (thats why I did a manual check to make sure there wasn’t a new update breaking things.


So, should I kick start it? I don’t mind, but I think the last time it produced the error messages afterwards. I can just let it go after I get it going.

I’d start with that. I’ve never seen a case on Windows where it didn’t update after a new install, only when later updates come along have I had to manually update (and sometimes the auto update works fine by itself). It can appear to freeze for a couple of minutes while it updates (with no progress bar or indication anything is happening) so give it a long while to update.


Awesome, things seemed to have worked.