SOLVED Why does this box appear every time I go to fritzing

I added a part to ‘mine’ from the internet (a controller for an LCD)
similar to this one
I can’t remember where I got the fritzing part, it works fine and I use it in my sketches but I get a box containing

The part ‘LCM1602 IIC’ at ‘C:/Users/Bob/Docupart to my ments/Fritzing/parts/user/generic_ic_dip_22_300mil.fzp_c7cab155adbdc5e675838ce7405e80cd_28.fzp’ does not have a unique module id ‘c7cab155adbdc5e675838ce7405e80cd_28’.

When I first go to fritzing.
Is there any way of stopping this and how do I do it?

1 Like

I usually hit this when making parts (with an error in the part) that crashes Fritzing. It isn’t too good about deleting files on failure (or for that matter when deleting parts :slight_smile: ). The cure I use (which is somewhat extreme) is to delete the 2 user data directories and start again. Note well this has the effect of deleting all of your Fritzing projects so make sure you have a good backup before trying this. On Windows the two directories are:

c:\Users(Win_user_name)\My Documents\Fritzing and
(at least this one is a hidden directory so you need to have enabled show hidden files in explored to get to it) If you move both of these aside by renaming them to (for instance) Fritzing_todays_date) Fritzing will recreate them both. You can then reload the parts and projects and the message should disappear. Note that is you have a lot of files/projects loaded this will be a pain in the ass! It may be possible to look in the data directories and find the duplicate part (which is likely what it is complaining about) and delete just that file, but thats a fair bit more complex to do (and you want to have a good backup before doing any of this as data loss is possible).

Don’t delete the whole dir, just the file in C:\Users\X\Documents\Fritzing\parts\user.

I think Steel had a work around where you delete the part from the bin, close and restart FZ, and load it back again

Actually trying to delete the part (if you don’t have an external copy already make sure you export it first so you have something to reload though!) is probably the best bet. I haven’t found that to work most of the time, because as noted Fritzing is fairly casual about deleting files bit its worth a try before getting deeper. As well I’ve had cases where I think something got hung up in the temp directories in roaming where deleting stuff in user. Experiment to see
what works (just make sure you have a good backup first!).

I can’t say I’ve had a problem, but I always close and restart. Fz doesn’t seem to refresh without restarts.

Edit and Save as new part, the delete old part might also work.

Open the LCM1602 part .fzp , at the top of the file you will have a line of code that looks something like this;

<module fritzingVersion="0.1.1201" moduleId="RioRand_LM2596_94ce9810d0922bc731e2f315085d46ab_1" referenceFile="resistor.fzp">

The "moduleId=“RioRand_LM2596_94ce9810d0922bc731e2f315085d46ab_1” is your unique module Id. Make sure you have a “moduleId” in the .fzp file. It can be just about anything you like as long as it matches the moduleRef in your Fritzing/bins/my_parts.fzb file and is not identical to another unique module id or moduleRef… It must be unique…

You can open my_parts.fzb in a text/xml editor. You will find a block of code that looks something like this, with the same .fzp name in the address…

<instance moduleIdRef="RioRand_LM2596_94ce9810d0922bc731e2f315085d46ab_1" modelIndex="85708358" path="C:/Users/Stephen/Documents/Fritzing/parts/user/RioRand_LM2596_94ce9810d0922bc731e2f315085d46ab_1.fzp"> 

You can copy one of the module IDs and past it into the other or just make up one and copy it into both. As long as they are the same and do not duplicate another part it should work…

After you enter the correct unique IDs into both files and save them. close Fritzing and restart it, Your little warning box should not appear…

thanks guys.
I tried to find the file LCM1602 part.fzp and only found three files with an svg suffix so I deleted the 1602 item and tried to reload it from here
I got a box saying this item (or at least the long row of numbers and letters referring to this item) were already in fritzing so I did a search of the parts and found another 1602. I don’t know where it came from (is/was) but I dragged it to mine which either copied or moved it there.
I shut the fritzing programme and restarted and the box has gone. solved. thanks for the pointers.

At least you got it working… the .fzp files are in Fritzing/parts/user/