[SOLVED] Unable to load custom part

I’m very new to creating custom parts. I decided to fix some issues with the NodeMCU custom part, but I cannot get my changes to load. I keep receiving the generic “Unable to load part from {PATH}” message and I can’t figure out what’s wrong.

The debug window shows 5 files extracted (which is correct from what I know), but nothing else. Is there another, more detailed, log that shows why a custom part cannot load?

Any common reasons for a part not loading?

I tried deleting the parts.db file and clearing out any old references to the existing NodeMCU, but still fails.

NodeMCU Rev2.fzpz (11.9 KB)

It is telling you the literal truth, there is no file to load. It is expecting the fzp file to be called

part.NodeMCU rev2_1f87da57808824c30deeb21088f90146_1.fzp


NodeMCU rev2_1f87da57808824c30deeb21088f90146_1.fzp

and the svg files to start with svg.layer name such as

svg.breadboard.NodeMCU rev2_1f87da57808824c30deeb21088f90146_1_breadboard.svg


NodeMCU rev2_1f87da57808824c30deeb21088f90146_1_breadboard.svg

when that is corrected the part loads but is still wrong. Running it through Fritizng check part indicates it is missing breaboard and scehamtic layerIds and schematic has no terminalIds (which causes this effect):

the lack of a terminalId in the schematic svg causes the connection point to be the center of the pin rather than the end as is correct. That is also why the part is aligned 0.05in off the grid in X. This part has the correct file names in it and loads (unzipping the fzpz file will tell you what the file names need to look like.)

NodeMCU Rev2-fixed.fzpz (12.3 KB)

You will need to delete your current part from the mine parts bin (by right clicking on it and clicking Remove part. Then you need to shut down Fritzing and save the mine parts bin, then restart Fritzing because I did not change the moduleId and file names in my part.


You are the best! I made the changes and it works!

Thank you for pointing out the schematic problem. I’ll take a look.