[Solved] Cannot load Parts

I have Fritzing installed on my Mac 10.12.5 running Version 0.9.3 (b5c895d327c44a3114e5fcc9d8260daf0cbb52806 2016-04-19) Cocoa [Qt 5.6.0]

I use Fritzing infrequently and started on a new project.

I do not seem to be able to show the Parts Bin.

When I checked for Updates I got a warning and tried to regenerate the parts database.
This failed with error “Unable to open temporary file”

Regenerating the parts database will take some minutes and you will have to restart Fritzing

Would you like to regenerate the parts database?

Unable to open temporary file

I reloaded Fritzing, which offered to update Parts, but failed in the same way.

Yet another reload which produced errors:-

Unable to find the following 13 parts:


I can run Fritzing, view my saved projects, and edit them, but cannot seem to get to Parts.

What can I do? I can live with losing all the existing parts.

While I’m on Windows not a Mac, the “Unable to open temporary file” sounds like a file permissions problem somewhere (unfortunatly fritzing isn’t very good at telling you what file it is unhappy with :slight_smile: ). I’d check that your user ID has permission to write to the parts directory (which is in the same directory as the code on Windows). It sounds from the last couple of messages that the parts database has become corrupted with a failed parts update. The cure to that (after you have exported and saved outside of fritzing any parts or sketches that you want to keep!) is to delete the parts and user directories which on a Mac are apparantly in /Users/username/Documents/Fritzing/parts (your parts, at least grab a copy of this before making changes!) and ~/.config/Fritzing (the database and probably what you want to delete). Neither of these files are affected by a reload so that your sketches don’t get affected by an update and if they don’t exist fritzing will recreate them.


Not sure how much help it will be … but I am on a Mac as well 10.11.16 El Capitan running Fritzing 0.9.3 as well.

I would do the obvious and restart the Mac and perhaps reload Fritzing. I am attaching a screen shot of the Finder window showing the various folders on my system in case that helps.

If you are comfortable executing unix commands from a command prompt window (because I don’t know enough about Macs to tell you how to get it in finder :slight_smile: ) the output from a

ls -lR ~/.config/Fritzing

would be useful in that it would show the filenames and permissions of the fritzing database directory (where I think the problem is) on your working machine.


I have solved my issue (which seems to have been a couple of problems).

Fritzing on macOS stores data in a number of locations:-

  1. Within Fritzing.app /Applications/Fritzing.app/Contents/MacOS/fritzing-parts
  2. User files, typically ~/Documents/Fritzing
  3. Configuration files ~/Library/Preferences/org.fritzing.Fritzing.plist
  4. ~/.config/Fritzing/backup

There seemed to be a number of issues:-

  1. .config/Fritzing only seemed to contain very old files from an old version of Fritzing, so I deleted it.
  2. ~/Documents/Fritzing seemed to have 2 parts lists, viz. my_parts.fzb My Parts.fzb
  3. When I deleted and reinstalled Fritzing I had 2 MINE parts, and was unable to delete either, and still was unable to update.

I backed up, then deleted ~/Documents/Fritzing ~/Library/Preferences/org.fritzing.Fritzing.plist
I reinstalled Fritzing (yet again) and it worked, and updated OK. I had to manually set Preferences.
I gradually restored all my User files, manually combined parts into my_parts.fzb and it now appears to be operational.

Thanks! The feedback may let us help the next person that runs in to a problem, and happy that you managed to get it resolved.