Several connections end up unavailable in new part


I’m new to Fritzing, but it all makes a lot of sense to me. Creating a new part seems to be a logical progression. But I’m having problems with getting some of my connectors to be available.

The board I’m creating has 61 connections: 28 terminal blocks, a 20-pin male header, two 2-pin headers, and the 5 (meaningful) connections from a DE-9 RS232 connection. There is some redundancy between the terminal blocks and the male header.

In the Breadboard view, Schematic view, or PCB view, I’ve been able to set SOME “internal connections,” but there are 12 of my terminal blocks that for whatever reason I am unable to select.

I have mapped a graphic to each of these connections in all three views. The corresponding connector in the Connectors list in each of these three views has a check by it. If I select a graphic in the list (with “Set Internal Connections” off), the appropriate graphic in the view selects as expected.

However if I enable “Set Internal Connections,” I cannot select any of these 12 terminal block connections to drag my connection.

Furthermore, when I open my part in the Fritzing application, I cannot drag a wire from any of these same terminal blocks, though I can from the other 16 (and, when I select one of the terminal blocks I had mapped an internal connection on to the 20-pin header, the appropriate header pin highlights – so that is working).

When I mouse over a working terminal block connection in the Fritzing application, it properly pops up the description specified for the connection in the Connectors view of the parts editor. When I mouse over one of the terminal block connections that isn’t working, I just get “Part 1”, the same text I get if I mouse over any other “dead” spot of the breadboard image.

The 12 connections that are not working are consecutive in the Connectors list, but there are connectors before and after them that are working perfectly well. I see nothing in the configuration that suggests any differences. (In my list of 61 connections, there are 6 that work, 12 that do not, and then 43 that do.)

FWIW, the SVG files for all three layers (Breadboard, Schematic, PCB) were generated from Inkscape (0.91), and I am using the Fritzing 0.9.2 on Windows 7/64-bit.

Can anybody provide any insight as to what I might be doing wrong?


– Barry

I’m no expert, so this is probably not going to help, but when you edit the part, in the last group “Connectors”, after Metadata", does the part have the right number of connections.

Other than that, maybe the XML grouping in Inkscape might be wrong.

Open the XML toolbox and go through where the “copper” parts are grouped.

I don’t know if colour makes a difference, but are all the connectors the specified std colour.

Maybe a re-boot.

Thanks for the suggestions, Old_Grey.

I suspect the problem must be rooted in the connectors in some way, because the same 12 connectors won’t allow for setting internal connections on any of the three main views (breadboard, schematic, PCB) in the parts editor.

However the Connectors tab shows the correct number of connections, and I can’t (in that view, anyway) see any difference between how those 12 are defined relative to any of the others.

Similarly, I’ve gone through the SML in my SVG files and don’t see anything unique to the connectors that I cannot connect.

I guess the next step is to try to open the Fritzing part file and see if I can find anything meaningful there. But I’m rather stumped.

I’ve even tried tweaking the graphics in Inkscape (saving as a plain SVG), reimporting, and reconnecting everything, but I’m not having any luck at all.

Any suggestions would be most appreciated. Thanks!

I just spent all of yesterday making a 12x1 rotary switch, and there was a lot of mucking-about with connectors - I’m not an expert -. When I Imported the part I had a lot of trouble assigning the connectors - FZ keep crashing -, so I went back and keep tweaking the drawings in Inkscape. Somehow I must have hit the right spot because FZ started accepting it - do them in order of tabs with breadboard connectors first and connectors last -.

Try clicking on the connector in the Inkscape XML box, and then along the top press “Raise selection to top (Home)”.

I think in the breadboard view in Inkscape the connectors only need 1 node each, schematic needs 2 per connection, and pcb only needs 1, but everything in the XML table has to be ordered and with the correct title groupings.

All the info I used was at the bottom of this post

I’m not very good - I’ve only made 3 parts - but If you can’t work it out do you have a link to the file so I can look at it.

Might be the speed of my system but I could not get on with the parts editor and making internal connections. I had more success directly editing the xml file fzp. At the bottom you will find a load of statements like

bus id=“internal1”>
nodeMember connectorId=“connector24”/>
nodeMember connectorId=“connector25”/>
nodeMember connectorId=“connector26”/>
nodeMember connectorId=“connector27”/>

The above would be an internal connection between connections 24,25,26,27.

Sorry don’t know how to add xml to this forum so leading less than signs missing

The Editor is what I was hinting at.

I don’t actually know XML, but I shuffle things about, adding, deleting, moving, in the Inkscape Editor (SHIFT-CTRL-X), until it matches the format of other parts that work.
The 5 boxes at the top of the editor looked greyed out, but they aren’t so work fine.
The Editor also helps because when you click on a txt node it lights up the object in the drawing.

I found out yesterday some parts have been converted from Eagle parts with a program the leaves a lot of useless garbage everywhere - had 8 rect on top of each other -, so there is some cleaning out required at times

Thanks, everyone.

I ended up in the XML editor and realized that the affected connectors were somehow not associated with the copper0 and copper1 layers, despite being in those groupings in the SVG file for the PCB.

I tweaked the XML for the SVG file and reimported the image for that layer and eventually made it all work. (As part of this exercise, I also ended up editing the XML for the fritzing part, manually resequencing all my connections. I had two gaps in my numbering sequence, and it was when I hit the first gap that the parts stopped being recognized.)

I’m not sure what tweak it was that fixed things, because I did a few layers of refactoring in all this. But something eventually worked, and now my part behaves.

So, thanks for the suggestion!

— Barry

TLDR: If you’re having problems with part connections not being recognized, use something like Notepad++ to edit the XML in the files – both the SVG image files and the fritzing part file – looking for differences between how a working connection is tagged and how a failing connection is tagged. As long as you don’t have the fritzing app open, you can edit the XML directly to try to fix things. (You did remember to make a backup copy first, didn’t you?)

I think probably in Inkscape group XML could be wrong . I’m no expert on this so many can only say that his opinion so small