Serial monitor problem with picaxe 08M2


I am running Linux Mint 17.3 and fritzing 0.9.2. I can successfully upload a program to a picaxe 08M2 using the “Upload” button in the Code view.

However, when I click “Serial Monitor”, I get a “Device or resource busy” error. At the bottom of the Serial Monitor window, it says “Serial port open error”. In fact, it does the same thing if I disconnect the serial cable. However, I can confirm that I can read from serial out because I wrote my own python script to do so and it works. I have tried to configure the serial monitor, but clicking the “configure” button doesn’t seem to do anything.

Any idea what I am doing wrong?

Let me know if I need to provide any more info.

Thank you.

Check to make sure you are a member of the dial out group ie;

sudo adduser yourusername dialout

Hi @landracer,

Sorry for the delayed response. I am already part of the dialout group. Otherwise, my python script wouldn’t be able to read from the device. Again, I can write to and read from the picaxe device just fine outside of fritzing. In fritzing, I can write but not read. Any other ideas?

Are you by chance running these outside programs via root?

Hi @landracer ,

No, I do not run the python scripts as root.


So last night a strange thing happened. I plugged everything in, checked the “serial monitor”, and it worked! I saw a bunch of garbage characters stream across the serial monitor window.

Now, the strange thing is that the “Upload” feature stopped working! After closing the serial monitor and clicking “Upload”, it would say “Running x” where “x” was the command to run the compiler and send it to the device. Except nothing happened after that.

Again, I could use my own python scripts to communicate with the device just fine.

It seems like there is a bug that prevents Serial Monitor from running if Upload has been run, and vice versa. Perhaps running Serial Monitor or Upload makes it appear that the device is busy to the other function.

Can anyone reproduce this behavior?