Schematic text notations (for voltage notes, etc.)

Is there a way to add text notes in schematic view? For example, I would like to add expected voltage readings at certain points in the schematic.

I have Fritzing V 9.3.

Thanks,
Frank

Yes two ways, if you go to the bottom of the core parts window in the schematic view area you can drag the text icon in to the schematic and put your text in that. Alternately you can select Edit->note which will give you what looks like a sticky note that you can add text to (which will stand out, which may be desirable in this case unlike the first method.)

Peter

I am aware of the “Edit>note” method but that gives a very large font in an overbearing yellow box and I need something about the same font size as the other labels on the components.

The text box from the core window seems promising as to font size if I could figure out how to edit the text… When I drag that box onto the schematic it contains the word “logo” and i can’t find a way to change that text.

Any ideas?

Thanks
Frank

Click on the text in schematic to select it, then in Inspector (lower right window) there is a field called text (with logo in the field) changing that changes the text. You can also change the font size by changing the poorly named shape field below it. Inspector will change many things about parts in the sketch. You could (with a lot more work) also load svg images with the schematic image icon if you want a particular format.

Peter

I don’t see anything that looks like the inspector you describe. I have a text box with “logo” in it, but I have tried everything I know to find the inspector but no luck. I even tried starting a completely new project but same problem

Sometimes when “adding a note” I have to zoom out to find the edit box, but that does not reveal the inspector for the “logo” text box. .

My next step is to upgrade from V9.3 to the newest version (V 9.4?) when I get a chance.

I’d love to hear any other ideas.

Thanks,
Frank

Ah! Learned something new. It is possible to suppress Inspector. Your screen should look like this (Inspector is outlined in blue)

but if you click the x (outlined in red), Inspector goes away to give you more screen room and is remembered in the preferences file (which looks to be what you have done at some point, perhaps without realizing it)

To fix that click Window->Inspector to restore the Inspector window (you can do the same to the parts menu if you need more screen room.)

Peter

2 Likes

Fantastic, I don’t know how you figured it out, but you did it.

And thanks for taking the additional time to post pictures.

I owe you one (probably two).

Thanks for hanging in with me.

Frank

You are most welcome. Others will probably also learn from it. As usual, trial and error is the way forward, you had obviously suppressed Inspector somehow, and the x is there. One it was gone there had to be a way to get it back and a search of the tool bar found that. Many things are poorly documented and passed along in here, this is just one more … We need to attract someone capable of doing documentation as well as developers but are having little success with either so far.

Peter