Rotating a complete pcb layout 180 degrees

Well, it was over 1 year ago that I was stumbling across this problem and it
was solved then. But now it happens that I again want to rotate the whole pcb 180 degrees. Tried to execute the above mentioned advice but failed.
When I now select the pcb and try to tick Sticky in the inspector, that area in the inspector turns blank. Nothing to select possible.
What am I doing wrong?

Works for me on 0.9.9 on Win 10

Select the pcb and set sticky

with pcb selected (although that doesn’t seem to matter!), left click and rotate 180 degrees

and as expected the board is rotated 180 degrees

Peter

If you click at some item, it will be selected, and the “all selection” will be lost. To avoid this, you can rotate the selection via keys (Ctrl-R , Ctrl-Shift-R, [, ] ) or via the inspector.
The inspector will show the last element selected before selecting all, and you can also use the inspector to adjust the angle. This is a bit odd, since it will allow you to rotate for example a breadboard by arbitrary angles, which is not recommended (you can’t place new parts there unless you rotate them as well).

For me the inspector only turns blank if nothing is selected. Setting a pcb to sticky in the inspector does not turn the inspector view blank.

Thanks for your responses. But non of your suggestions seem to work over here. Perhaps it has something to do with my computer O.S. : PCLinuxOS-64bit.
I do not know. My fritzing version is 0.9.6.
This is what I see when executing the suggestions:
First I select for instance the boarder:

Then, after selecting all, this is what the inspector shows: blank.

Ctrl-R or Ctrl-Shift-R does not give any effect.
In the mean time I found some work around:

  1. Deselecting “locked” and “Sticky”
  2. Select all and hit the Ctrl+C
  3. Then Ctrl-N for opening a new design and paste the layout in that
    new design.
  4. Then it is possible for me to execute the “Rotate” function.
  5. Select everything again and copy-paste it back to the original design.
  6. Delete the old one there and that’s it.
    But then I discivered that I again had to activate
    “Set Ground Fill Seeds”. :slightly_smiling_face:

If you post the .fzz file for the above, one of us can try the same thing and see if it works for us (which should tell us if it is something specific to your system.)

Peter

Here you go:
RIAA-Equalizer-Forum.fzz (54.2 KB)

On 0.9.6 and 0.9.9 under Win10 I need to select the very edge of the pcb to get pcb (rather than ground fill) with locked set neither rotate nor cntrl-shift-r rotate the image. Note that the single / double sided field in Inspector is blanked out which it shouldn’t be.

but unselect locked and cntrl-shift-R (or left click rotate) work both work

The blank Inspector panel I suspect is caused by losing the select. I need to have the cursor on the grey line just above the ground fill in order to select pcb, it blanks the Inspector field if that isn’t true.

These are from 0.9.9, but 0.9.6 acts the same.

Peter

Peter,
If I do exactly what you did: select the pcb “just above the ground fill” then it does not blank the inspector but it selects only the contour of the pcb and not the whole pcb (which I want to do) to execute the rotate. The moment I selecting “all” this action blanks the inspector and thus the rotate possibility.
Or do I misunderstand you?

I think you understand me, your system seems to be running differently though. This set is 0.9.6 on Win 10. If I select the grey edge (the image capture loses the cursor) shown by the green arrow I get pcb1 selected in Inspector and if it is not locked I can rotate it(and I’d expect you should be able to as well!) How are you doing “select all”? For me just clicking on the grey edge selects pcb1 and that should do what you need.

If I select in a little further on the copper fill, I select the copper fill and can’t rotate it.

the only way that Inspector blanks is clicking in the blue background to unselect every thing.

I’d expect Linux to react identically, but it doesn’t sound like your installation is doing so and I don’t know why. It should be identical across platforms pretty much as far as I know.

Peter

Peter, I think I have found the procedure for my problem:

  1. I select the edge after unchecking “Locked” and “Sticky”

As you can see the inspector is still active and notice that in the down left corner that “Rotate” icon is also active:


then:
2. I go to “Edit” > “Select All” then, after all is selected, the inspector keeps active:

but that “Rotate” icon at the left bottom isn’t:
Rotate-Problem-11b
I do not know why nor I can understand it but the inspector keeps active
so I can modify the angle and after that, I then click somewhere in the canvas and: Done!! But as you can notice the inspector turns blank:

Ah! This explains it. We are doing the same thing in different ways and getting different results (which may indicate bugs!) Here, on 0.9.6 I did what you did and used Edit->Select all. Inspector is blanked although everything appears to be selected (I expect this is a bug as I think Inspector should be active with pcb1 selected as happens with the cursor!)

if I click on the edge of the pcb to select pcb1 Inspector becomes active but with the part locked but not sticky (which may be important!)

so change to not locked and sticky on pcb1 and see if anything changes. Nope can’t rotate the pcb either via the rotate icon or cntrl-r. However clicking on the edge of the pcb to select it with the mouse allows rotation either by the rotate icon in the tool bar or right clicking on pcb and selecting rotate in the drop down menu (which is what I was doing) so it looks like the problem (if there is one, this may be expected behaviour for some reason!) is the Edit->Select All doesn’t select in a way that allows rotation. It looks like it may be the copper fill which is the issue. If make a sketch without copper fill, edit select all appears to work:

Then edit select all and click the rotate tool bar icon and the image rotates as expected:

even though Inspector is blank, so I would guess the copper fill is affecting the rotation for some reason. Fritzing 0.9.9 appears to react the same, it won’t rotate the .fzz with copper fill, but will rotate to resistors without the copper fill (or possibly some other characteristic!)

Peter