Program dies when I try to do a file open

My Program version is Version 0.9.3 (b5c895d327c44a3114e5fcc9d8260daf0cbb52806 2016-04-19) 64 [Qt 5.6.1]
I get no error messages.
I am using Window 10 with all laterst updates

As far as I know this is a new one. Some suggestions: try deleting the user directories (if one gets corrupted for some reason such as a failed parts update odd things can happen):

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will receate them, or you can move them aside by renaming them if you want to keep something in them.
If that doesn’t work the only other thing I could at the moment suggest is in Friting Help tick enable debugging log which will open a debug window which may provide some illumination (or may not :slight_smile: ). Deleting the user directories is probably your best bet though.


Thanks for the sugestions, but still no luck. I removed the suggested files and same result - I get a windows popup that say that “Fritzing has stopped working” with the only option to close the program. I tried the debugging log, and the next time I open Fritzing, the debug txt says “Check new version no error” I then deleted all fritzing files (program) and reloaded fritzing from the zip file. I run Fritzing and click on the file open bug and I get the same result.

Yeah, I am having the same problem!

This is a new fault as far as I know. There have been problems in parts search on Win10 when some of the windows patches have failed, but not file open as far as I know. If you don’t try and open a file (which I know isn’t useful :slight_smile: ) does it continue to run? If so you might try clicking on help->check for updates and see what happens. Fritzing tries to check github for new parts at every startup, and sometimes (especially if it got interrupted) the parts database gets corrupted but deleting the user files usually corrects that as long as it completes correctly on the reinstall (it does pause for a longish time on startup while it makes does the update and there is no progress bar or indication it is doing anything, you just have to wait and it will eventually complete). Its also possible that the latest patch set has broken something (although it hasn’t for me on Win7). The failure (a windows popup that Fritzing has stopped working) is typical of a corrupted parts database though (that is usually the c:\users\username\AppData\Fritzing\roaming\Fritzing directory), I believe there is a Fritzing bug that an exception doesn’t get handled somewhere if the database gets corrupted (or in my case when I screw up making a new part, which shows up as corruption in the parts database :slight_smile: ) and that is how it shows up, but deleting the two directories and starting again (after correcting the error in the new part) has always fixed it for me. I take it that the debug console doesn’t say anything useful when you try and open a file and it fails? Other than that I’m out of suggestions, hopefully someone else may have an idea.


What is this file. Is it a .fzz that you created, or a .fzz you found on the net.

I don’t get as far as trying to select a file… A window pops up where I would select a file to load but before I can even look to find a file, a windows popup tells me that the fritzing program has stopped responding

The debug console show nothing useful. If I do not try to open a file, the rest of the program seems to work.

This is a weird one! A couple of weird suggestions: check the file manifest of the install zip file to make sure your av didn’t quarantine a program. This failure is a Fritzing bug which will also occur if I screw up a filename in a new part (so the listed file name doesn’t exist). I think the open fail exception doesn’t get handled somewhere and frtizing hangs exactly as you describe (although only when I open the new part which isn’t the case for you). The other out there suggestion is delete all the directories (the install, and the two user directories) then disable the network connection and do the install with no network connection. This will block the parts update from github, and if fritzing then works that would indicate a new parts update is what is causing your problem (likely because of a missing file). That would at least give us somewhere to look. Other than that I’m pretty much out of ideas!


I checked my quarantined files and found no fritzing files. I deleted all the fritzing files, as you suggested. I downloaded a new copy of the fritzing program. I disconnected the internet. I unzipped the download and ran the .exe which installed fritzing. I opened the program, made a very simple schematic, and did a file save as. Windows file dialog opened, and then shortly after and get the message that the fritzing program is no longer running with the only option of quitting the porgram. same thing happens if I rerun the program, and select file open. All this occurred with the internet disconnected.


The only thing I can think of to suggest is (if you are willing!) try running Friting as administrator. This sounds to me like a permission problem somewhere (combined with a Fritzing bug where it doesn’t deal well with file errors). As administrator it should be able to write pretty much anywhere (which may or may not be desirable :slight_smile: ). If that works then we need to figure out what new file has been written and look at the permissions on where it is. The only other thing I can think of is to use the Microsoft trace program (which I have heard of but never used) to see if it can tell you what file it is trying to open when it fails (as I’ve never used it, I don’t know if it can do this).