Problems with CamdenBoss and core folder

I use the 0.9.3 version of Fritzing on my pc and the same on a new one.
I’m trying to modify a recent project created on the first pc, on the second one but when I open it, fritzing gives me this error

This part apparently must be in the core folder, but it isn’t in it.
I tried to move the file from the folder of my first pc to the core folder of the second one :upside_down_face:
i know that it is not a good procedure but I cannot import it in other way and I dindn’t find it online.
Obviously it doesn’t works…

How can I solve it? I need that simple parts…


Export the part from the first computer using Fritzings parts menu and then import the part to the second computer using th parts menu again.

Parts update on Windows is currently broken because of an outdated git2lib. There are several fixes: move the folder from your current machine to the new one, then update the parts database via Part->Regenerate parts database (which will update the database then exit Fritzing, on the restart the new database will be in use). Alternately you can clone the fritzing-parts repository from github in to fritzing-parts and regenerate the parts database.


In a third pc I have the same problem but today Fritzing asking me to check new parts, cleaning modified files and update new parts. In this way it works.
In my second pc proceding only with the regeneration doesn’t work. I must check for updates, cleaning, update and Now it works!

Ah, obviously you are on Linux or a Mac, so parts update will work. Only Windows appears to have the problem. Good that you got it fixed in any case.


I’m on windows, but good for me that it works anyway! :wink:

Which Windows version, Wn7 or Win10? None of my Win7 boxes work, the libgit2 in the distribution file only supports tls1.1 which github no longer allows and I can only get it to work on a compiled from source dev version (and that dll doesn’t work when substituted for the libgit2.dll in the distribution. I have been assuming updates are broken til we can get a new source build done (which I at least am haveing Qt problems with).


Mine are Windows 10.

Interesting, I’ll have to boot a Win10 box and try that. I’d expect the tls1.1 version to break either version of Windows, but perhaps 10 finds some alternative transport that Win7 doesn’t have.