Problem with PCB View Silkscreen Image

I am not sure what I am doing wrong here. I have a logo that I created, and from what I gather from this forum I can save it as a PNG file and add it as a silkscreen part on my PCB. I created a 10mm-500dpi image and exported it to a PNG. Everything looks fine with it but when I load the file I get this broken image. Anyone have any ideas what I am doing wrong?
problem_with_logo_fritzin

I tried it in black/transparent BG, white/transparent bg, black with white bg and white with black bg and I get the same results. Here is the PNG with a black background and white text.
logo

What Fritzing version are you using? It works fine for me on Fritzing 0.9.9 on Win10 (there are a variety of fixes for images in 0.9.9!) Drag in the silkscreen image in to the sketch. Then in Inspector (the lower right window) click Load image file and select the image. Results in

and gerber output (using gerbv)

Peter

Works for me too, using a Fritzing 0.9.6 (from flatpak) on Fedora 33.

Only Idea I have is to verify that you are using the “Silkscreen Image” part from the “PCB View” of the “CORE” bin in parts.

That is strange. I am using version 0.9.9 on Windows 10. I am adding this as a silkscreen image. As soon as I pick “load image file” from the Core Parts inspector I get that garbled image. Maybe I should uninstall reinstall Fritzing???
version
silkscreen
silkscreen_after

That may be a good bet. If you don’t have custom parts (or maybe even if you do) try removing the user files too as they won’t get changed during a reinstall and something in there may be the issue.

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you want to keep something in them.

linux

~/Documents/Fritzing/parts
~/.config/Fritzing

Mac

/Users/username/Documents/Fritzing/parts
~/.config/Fritzing

It may also be worthwhile to upload the sketch with the corrupted image loaded (the .fzz file, upload is 7th icon from the left in the reply menu.) I can extract the png image from the .fzz file and see if it is corrupted there and if it displays correctly here.

Peter

I think I will give that a try. I tried just a new blank project and just added that one image to the PCB view and it came out the same. Something is not right with the installation. I do have all of my custom parts saved off separately for quick import again if I wipe everything out and start over.

Thanks

No luck. It has to be something else installed on my system that is causing the conflict. I wiped out everything and started over with an uninstall/reboot/reinstall. I tried just a blank project before importing all of my custom parts and the same issue. Guess a custom logo on my PCBs is not in the cards for me, unless anyone else can think of another cause for this. Thanks for the suggestions.

I did solve this another way for anyone that might run into the same issue. I brought my logo image into Inkscape. With it highlighted, I chose Path>Trace Bitmap. I then deleted the original and then in Document Properties did a Resize to Content. I exported that out as a SVG and it worked great. The image is much sharper than the PNG file was. (Inkscape, for those who do not know while reading this, is a free vector drawing program that is also great for creating custom Fritzing parts.)