Problem Installing in W10

W10 pro 64 on i5 750, 12G RAM
Downloaded v0.9.3b.64

After starting Fritzing, the software appeared to hang with a [Not Responding] message in the title bar. Leaving this for a -l-o-n-g- time eventually brought a message about ‘cleaning files’.
Agreeing to this something started but again showed a [Not Responding] message. A while later a ‘Check for updates’ message appeared. Agreeing to this brought a short period of downloading followed by another long wait. Eventually the process finished and the software was restarted seemingly OK now. (Took about an hour)
The [Not Responding] messages led me to abandon the intallation several times before trying it on my laptop and then proceeding as above.

This was in stark contrast to installing the same file on my W7 pro 64 AMD (slower) laptop where all of this was much faster taking less than 5mins even though connected via WiFi rather than ethernet.
Hope this helps someone.

I have come across the same error, I noticed that “loading new sketch” progress bar was red and only went to 49% before the front page came up wit the “Not Responding” message.
I to have tried to multiple downloads have been doing this for over 3 hours with no success.
I will follow the above procedure and see if it works for me.

Followed the procedure and looks like it worked. Fritzing is now responding for me.
It took about 15 minutes for the cleaning and loading new updates.