Power Symbol connection error

There seems to be a problem with the Power Symbols.
Fritzing 0.9.8 on Win 7.

I placed a 4001 from core parts and two different Power Symbols and connected as below…

The problem is that Fritzing connects pin 2 and pin 14 together as can be seen in the PCB view.
Power Symbol 2

Also, I have a project that has three voltages, 5V, +15V and -15V (for the op-Amps). I can only find 5V, how do I set power symbols for the other voltages?

This looks to be a bug. It works as expected in 0.9.3b and 0.9.6 (not shown here):

but not on 0.9.8:

Since I have the above screen shots I’ll open an issue on github. Downgrading to 0.9.6 should be a work around.

You can set the voltage in Inspector, either by using the pull down menu or typing the voltage you want in the voltage field (because 15V isn’t in the pull down menu!)

edit: Issue #3882 on github.


I’m sure I tried this before! Yes you are right, you can enter any numeric value.

I will use Net Labels to get around the power symbol bug.

The part needs to be in a sketch for it to work, if you tried it with the part selected in the parts bin it won’t work, Inspector can’t change the part in the part bin (that has bitten me more than once!)


Sorry for this, it was my fix of the net labels which broke the power symbols. I made a pull request to fix this. If you are able of building the code, you can try it and test it. If not, you will have to wait until the next release.

We are testing 0.9.9 (that has this fixed) and will release it today if no issues arise.