Pins Not Lining Up With Breadboard

I’m having the same issue as in this post from a few years ago where the pins aren’t always lining up with the breadboard. Any ideas on why it is happening or how to fix? It is happening sometimes, but not all the time, though it seems like once it starts happening on a specific breadboard, that breadboard doesn’t function correctly so I just have to move everything to a new one.
In the screenshot below, the right board is working correctly, the left board is not working, using many of the same components on both.

Breadboard Layout Doesn’t Line Up - beginners - fritzing forum

The usual reason (although perhaps not in this case) is misalignment on loading of the breadboard when Fritzing starts. The cure is to enable snap to grid (it is usually on by default but can be off if the previous sketch disabled it.)


and then move the breadboard so it snaps to the grid. I tried a couple of times to get a breadboard to load out of alignment but of course it won’t work for me right now (every try is on the grid even when I went back to 0.9.10 in case this is fixed in 1.0) so I faked it by turning off snap to grid and moved the breadboard 0.05 in off the grid in x and y like this which is the typical load misalignment that I have seen (and what looks to be occurring in your image):

note the breadboard holes are not on the 0.1in grid. Here I enabled snap to grid again then moved the breadboard so it snaps to the grid.

and now it is properly aligned and should work correctly.


You can get the same symptom if the grid size is not 0.1 inch.

I’ve played around with it to see how this issue is happening. I do have aligned to grid checked and the components seem to be able to line up most of the time so it’s not one specific thing having a problem. The most consistent recreation I’ve been able to come up with is using the half+ breadboard size (though other sizes are having the same issue also). Components will align fine until you move the breadboard. In the screenshot attached, I placed a few components which were fine, and then moved the breadboard (which kept the attached components fine). The subsequently placed components, however were not aligning correctly. I had turned on bendable wires and wondered if that triggered the problem but turned it back off and the problem persists.

In the full size breadboard I also seemed to have a couple spots that were registering connections where nothing was connected, which could be related or a separate issue.

Huh! Which operating system are you on? On Windows 10 and Fritzing 0.9.10 I can’t reproduce this. Here I changed to a half+ breadboard added a resistor and a couple of LEDs then moved the breadboard a bit

and then dragged in another LED and resistor but they align to the grid properly and connect when dropped.

Unless I just haven’t tried it enough times to trip the bug (assuming it isn’t something specific to your system!) It may be profitable to try clearing the user directories (saving the current ones if you have custom parts!) to see if that helps. I haven’t seen other reports of this particular problem either and I would expect someone would have commented.

"There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you want to keep something in them.





edit: another possibility just occurred to me. It is possible that moving the breadboard is changing which pin is aligned to the grid as the power strips are offset 0.05in. Indeed that looks to be the problem here (which I still can’t reproduce though) as your image above has the breadboard aligned to the grid on the power strip which puts the component strips 0.05in off the grid:


Here the power strip is aligned to the grid but the main pads are now 0.05in off the grid, The solution to this is probably an enhancement request (that is active I believe) to be able to specify which pin aligns to the grid (it is currently a mystery which pin Fritzing chooses although it is supposed to be connector0, although breadboards don’t have a connector0 and I have seen odd results from tests. This won’t happen on the full size breadboard because the power strip there is aligned to the grid:


Hi there,

Lately I’m working a lot with the Half+ breadboards and I can confirm that the strange behaviour happens sometimes, even with all the “Align to grid” and “move to re-catch” actions.

My suspicion is that, as this breadboard has power lines that are half a mil moved laterally, sometimes it triggers the behaviour…

How does Fritzing “select” the “main pin” to align components to the grid?

Best regards

Edit: @vanepp was editing his post as I was writing mine… :sweat_smile: Same idea!

That is the question of the day! As I said in the edit above there is an issue (not an enhancement request) here on github to fix this. At present how Fritzing selects is a mystery. Testing tells me it isn’t as simple as always connector0 I wasn’t able to figure out what it is selecting on.


A work around (not a solution), is to set the grid size to 0.1 inch, place a part (not on the breadboard), change the grid size to 0.05 inch, align the breadboard with the part, lock the position of the breadboard, then change the grid back to 0.1 inch. All further part placements should then align to the main part of the breadboard (but not the bus lines).

Thanks all for your tips! I haven’t had a chance to play around with it the last couple days but these suggestions give me some things to look out for at least. :slight_smile: