Parts search vanished on latest download

Hey guys,
So I did the Fritzing update when asked and now I don’t see a search bar on parts. It’s probably my most useful feature since there are tons of parts to choose from.

I tried renaming it, re-installing etc. I just finished a new clean install and downloaded from scratch but no avail.

Running latest Sierra with Latest Fritzing (0.9.3).

Any thoughts or help? Here is the screen shot of my parts bin:

Two suggestions: scroll down the selections in parts sometimes the search moves to the bottom of the list. If that isn’t it then try deleting the user directories (note you will lose all your sketches and imported parts doing this so back them up first or just move the directory aside and replace it). I assume Sierra means this is a Mac (as there have been lots of these types of problem on Windows but not so many on the Mac)? Note that reinstalling Fritzing does not reinstall (or change) the user data (your sketches and parts) or temp directories and sometimes that is what gets corrupted. I think on a Mac the user directories are in a . file in your home directory (I’m a Windows user).


ugh i didn’t get notified of this. what you mean deleting user directories?
I’m aware re-installing doesn’t delete/replace user data or some of the settings… I did go from completely clean osx copy though so should be nothing else bugging it.

I don’t see a .fritzing or any other in my home directory or documents… i’ve tried searching and deleting.

It’s sad cause without the ability to search for parts it pretty much renders fritzing useless. I spend more time looking for resistors then actually building things :frowning:

This is not the first version i’ve had issues with. I switching to for a while hoping it would get fixed in an udpate/upgrade but to no avail :(.

Fritzing has been awesome for teaching and getting parts done quickly. I’ve donated in the past and if I can help debug I’ll gladly spend the time but as is I can’t continue using it.

The lack of notification was likely my fault, I tend to use the general reply button (which doesn’t email notifications) unless (like this time) I think about it. With the warning I’m a Windows Fritzing user not Mac, there should be a directory (from the parts file format doc at)

called ~/.config/Fritzing on the Mac (which may be hidden because of the . in front of the .config on Unix utillities, an ls -a in a command prompt should display it). On Windows you have to specifically enable displaying hidden files to display it. This directory is the parts database which sometimes gets corrupted and your user sketches are in


apparantly (I expect as with windows you need to replace username with your Mac user name). On Windows 10 (which I also don’t run :slight_smile: ) some of the latest updates have broken the search function for reasons unknown so there are two possible causes (database corruption being the other) in Win 10. I think this is the first case I’ve seen on the Mac of this though, so I suspect that the issue is possibly corruption in the ~/.config/Fritzing directory. Also (assuming you are using Fritzing .93b) it updates the parts database from github at startup and if that gets interrupted that can corrupt the parts database. The github updating has been a problem on some of the older Macs lately but that usually hangs the app and turning off networking so it doesn’t try the update has fixed that for some of the folks. Hope some part of this helps!


I’ve had this issue of the search option missing for sometime on a Windows 10 PC. I found that Fritzing files were being stored on my OneDrive now. The search bin search.fzb was there. Noting that the my partsd bin was now called My_Parts.fzb I renamed searcj.fbz to My_Search.fbz and hey presto a search appeared in Fritzing bins at the bottom of all the bins. In fact two searches appeared both with magnifiers but one has no entry field for searching. I also note that search.fzb reappeared in the OneDrive directory along with the My_Search.fzb.

Hope this allows you to fix yours (even if a little clumsy solution) and the developers to hunt down a proper solution.


Now that development is starting again, there is some hope of a fix. It is still unclear (at least to me) how this problem occurs though. I suspect it may be permissions on files (and Fritzing not checking return codes on file writes). I’ve never seen the problem on Win 7 Pro, but I don’t have OneDrive or netbios file sharing enabled and that may be why.