Parts Bin and Parts Location

I’m cleaning up/deleting old files and down to the last bit of cleanup and see several Directories of Parts - I must have done something along the way and end up Confused::frowning: and need some clarification/help on:

Question 1). What Part Bin’s are needed and where best to locate them…
(I want a bin for temporary Part work and a bin populated with the Core parts I use and My finished Parts…

Question 2) What & Why fzb and .fzbz ?

Question3) Why do some appear to save in User, others in Contrib ?

I have these Directories and Files in Documents>Fritzing>

You’ll see different parts show up in different locations and there seems to be multiple copies of parts…



easy questions first. The fzpz is a zipped copy of the fzb (which is a bin file)

In the mists of time, core parts were supposed to be (and are) in core. The fzp file in core and the svgs in svg/core/breadboard …/icon …/pcb and …/schematic the mists start with user and contrib, I think that contrib was for contributed parts from the community (of late years they have been going in to core). On my system contrib is empty except for placeholder.txt and usr has only 74xx08.fzb with the svgs in …/svg/user/breadboard etc. There is also obsolete (which you want as well) which contains older versions of core parts that have been obsoleted by a newer version. If you load an old sketch it will offer to upgrade your obsolete parts with current versions (with variable results). As far as I know there is no documentation on the obsoleting mechanism, its on my list to figure out what it does and document it.

question 3 is more of a mystery. On my system (with no bins of mine in place) I have

bins/more the png files for the bin icons

bins/contribParts.fzp (a parts bin with about 8 parts in it, I don’t know what exactly, actually the 13 parts in bin contrib in the main parts bin I expect)

bins/core.fzb (a parts bin with all the core parts.) All the core parts

There have been reports in the past that Fritzing does odd things with bins if it is unable to write the bin directory (likely not checking return codes and just proceeding with odd results.). What I’d suggest is rename (to preserve them) the documents and ~/.config/Fritzing and let Fritzing build new ones on its next restart and populate those in the manner you choose. I’ve not worked with bins all that much.
There shouldn’t be duplicate parts, the parts with the same name slide_switch…27dco_1.fzp and slide_switch…5666b_1.fzp are likely different variants of the same part that can be selected in Inspector in the pull down menu.


Thank you.

I got it all cleaned up and setup in a more useful way.

Don’t know why Three Bins called “Mine” show up in the parts panel. Regardless, I now have:
One bin called “Mine” containing my useful Core (Fritzing) parts.
One bin called “Mine” containing my Homemade parts.

And, it’s weird but, the Third “Mine” bin is a duplicate of the Second “Mine” bin with Homemade parts. But, if adding a part to Mine#2, that part isn’t consistently added to Mine#3.

Naturally, I don’t need the duplicated (unreliable) “Mine#3”.

Still, I think Fritzing is far better than all the other similar apps… I’ve made well over 100 actual PCB’s using it (mostly for CNC milled, along with a few Etched boards).

I don’t think we know, it is thought to be maybe permissions problems somewhere, but I don’t know of anyone that has managed to reproduce creating extra bins (there are a number of old posts for cleaning up after it though :slight_smile: .) This is on my bug list but lower than a lot of other issues. It was also moot until we managed to get development restarted for everybody but me (I could fix the bugs for me, but not distribute them to others.) Hopefully we can start chipping away at some of these (0.9.4 already has a start, two of my most annoying are fixed in there, the crash and database corruption from a corrupted part and Parts Editor not deleting part files when you say “don’t save” are both fixed. It looks like the 0.9.4 release is moving forward, there is a release candidate (currently lacking Windows and Mac binaries due to tool chain problems) on github.

edit: If you figure out how to create an extra mine bin, I’d be interested in the steps. If I can recreate it, I can use gdb to trace the code and maybe figure out how to fix it. Without an understanding of the code base this is my only choice (and it is painful but works!)

SOLVED, as follows…

I located (in OSX Sierra) under User… the Fritzing “plist” file in:

[user’s] >Library>Preferences>org.fritzing.Fritzing.plist

With Fritzing closed.

I opened the file and found things of interest (two screenshots below) with contents that provide a Clue.

Thinking that with only One section re “my_USEFULL” and two sections of “my_parts”, I concluded that, because I did not have duplicates of “my_USEFUL”, the problem must be duplicates of “my_parts” in the Plist.

To ‘Aid’ in solving this, I Deleted ‘Both’ sections of lines referred to/contained in bins2.3 and 2.4.
Saved the file.

I Deleted both of my Bins (my_Useful… and my_parts…) folders.

With the Edited PLIST and Deleted Bin’s, I booted up Fritzing. Empty “parts” and “bin” got re-created.

Now, only One “Mine” bin appears in the Parts Panel (That SOLVED the duplicates of bin’s ).

I imported my Homemade parts (individually) into the “Mine” bin. Saved and Exported it.

I imported my previously exported my_USEFULL fzbz bin. Saved and exported it.

Final Results in Parts Panel:
One “Mine” bin with my Useful Core Fritz parts.
One “Mine” bin with my Homemade parts.

(pay no attention to the #1 text in screenshot - purely for my management of screenshots…)

Now, a Happy Camper :smile:

Good, now I know a bit more about bins and other folks with this problem have a place to start! I guess we should start a FAQ with the various known workarounds to problems, but as always too many problems not enough time!


Forgot to answer the Question of ‘How/Why’ duplicates of “Mine” happened. Foggy memory (and without bother to confirm it, now that all is well and don’t want to mess with it) but, I’m thinking the dup “mine” came about from (perhaps) selecting “New Bin…” in the bin’s tab… Sounds logical…

Thanks I’ll try that and see what happens. Reproducing could lead to a fix!