Part label on cursor, can't hide it

When I move the mouse on the breadbord a part label appear on the cursor. I tried to get rid of it on show/hide part label under the part menu but nothing happen. What should I do?

Assuming you mean the pin label (circled in green hrere)

It isn’t suppressible, if you hover over a pin that label will be displayed to tell you what pin it is.


Yes it is, but the cursor disapears as soon I get it to the board and is replaced by some kind of black dots and eventually showing the info on parts and pins but since there is no cursor it is difficult to select the pin in the parts to edit the sketch. See the images:

As you can see in the pictures there is no cursor, it is replaced by some kind of dots and black spots with the name of the part. I use win10.

For me on Win10 that doesn’t happen. The cursor remains a normal black arrow (although Snip & Sketch doesn’t display it when I capture the image.) I am however still running the pre release version of 1.0 not the released version yet so it may be a 1.0 bug (as there are a couple of commits after the pre release.) What Fritzing version are you running?


Version 1.0.0
(rcCD-4157-0-6b14cfe9 2023-06-02) 64 [Qt 6.4.3

Try to follow the workaround mentioned in Mouse pointer strange behaviour · Issue #4037 · fritzing/fritzing-app · GitHub

I tried the two workarounds: Compatibility(win8) and DPI setting None is working for me…
How can I get the previous version?

If the download link takes you to the downloads page, then older versions (0.9.10 in this case) should be at the bottom of the page.


DId you check the workaround mentioned in the github issue?

I think it does not mention Win8 compatibility, and it is the “High DPI setting” for Fritzing.exe, not the “DPI setting”. Otherwise I would have no explanation why the workaround doesn’t work.

The issue definitely happens because of a decimal zoom factor like (1.25, 1.5 or 1.75) that gets applied to the mouse pointer. Old versions of Fritzing would round that zoom factor to either 1, or 2. (meaning 100% or 200%). Since the old versions are limited to these zoom factors, you might as well use Fritzing 1.0.0 and set the zoom factor to 100% or 200% .

For future readers: Fritzing 1.0.1 should not have this problem anymore, we have changed mouse cursor images to a scalable representation.