No search function for parts

Hi All

Hope you can help. I have the downloaded direct from Fritzling two days ago and have the version shown in the screen shot. The search function is missing for the parts bins. It is not in the area its meant to be nor is it anyway amongst the parts listed.

Ive done a search of the issue and read the posts on it. Some have been too technical for me to follow but I did allow the permissions for the program on Bitdefender. I have deleted and re downloaded 3 tines and no change. Im running it on W10 64bit

Has there been a simple repair for this issue anywhere?

Thanks for any help as not having the search function for parts makes this program unusable for me.

Check to see if you have a “search.fzb” file, probably in “My Documents\Fritzing\bins”. Check the [bins2] entry in the Fritzing.conf file. I do not know where that is stored for Windows. On linux, it is “.config/Fritzing/Fritzing.conf” from the users home folder.

The first lines under [bins2] should be something like:

0\path=«path\to\user»\My Documents\Fritzing\bins\search.fzb

On windows that path will (should) likely start with “C:\”. If there is no entry for search.fzb, that is the problem. Search down for “search.fzb”, just to make sure it is not somewhere else in [bins2]. It should be the first entry, with number “0”. If missing, you can try manually creating it. If there is a “My Parts” entry, you can copy it to get the correct path for your environment. Your screen shot does not appear to have a “My Parts” bin either. It is normally right after the Core bin that is being shown in the snapshot.

Instead of manually correcting the Fritzing.conf file, you should be able to delete it, and start Fritzing again. I believe that Fritzing will recreated it (correctly) when it does not exist. I also believe that uninstall/delete leaves the config file behind, and that an install will not touch it, when it already exists. So if it got created incorrectly during the first install, or first run after the first install, it stayed around to cause problems later.

As to why it would be incorrect in the first place, the only thing I can think of, is that Fritzing was unable to create the “user” folder the “Search” (and My Parts) entry is supposed to point to. That would normally be the “Fritzing\bins” folder inside of “My Documents”.

To maybe get more information, try running Fritzing from a command line window (cmd.exe). The output on startup may say what it tried and failed to do.

Hi MicroMerlin

Thanks for the detailed reply and support. Ive spent the last couple of hours looking for the suggested files and not much luck plus Im not good at this side of computing where program files are concerned.

I found search.fzb but nothing for Fritzing.conf with searches on C drive, documents, this PC, desktop (where I saved the files) or anywhere else. I also searched for ‘bins’ and still no luck.

This is all I found:


Sorted, after few more hours mucking about deleting and re loading I now have the search option. Thanks for the support