Missing pads on SMD part

Ok I did something stupid and tried creating a new part by editing an existing part and ended up exactly where I always do when I edit an existing part, with an unusable part.

I found something that was SOW-20 and I needed SO-20 so I narrowed the pads a little and proceeded to change the SVG and Metadata to be a 74HCT245.

I can use the part as expected but when I export the Gerbers I have ZERO pads for this part. I have found that in the parts editor under metadata it says (flipped smd = true) and when I try and remove it it just comes back. I have tried exporting the part, unzipping it and looking in the fzp file and there is no flipped smd = true in it so I am not sure what is wrong.

As you can see Fritzing does know the pads should be there because it still avoids those areas while doing the ground fill. It does not create the pads or solder mask or paste mask layers when you export the Gerbers though.
Screenshot from 2018-03-01 10:55:25

Broken part removed. See Missing pads on SMD part for the fixed part.

Does anyone know what is going on or how to fix it?

P.S. As you can see by the dotted line and scissors this is an optional part that when installed you have to cut the traces.

Public enemy #1: transforms. I first thought you had tripped magic code in the fzp file (and by the way on Windows the flipped smd=true doesn’t show in parts editor) so changed varient and other things in this particular fzp so don’t use it because it may not be entirely correct. Then I looked in detail at the pcb svg. Transforms in the multilayer groups. So I ungrouped everything then regrouped copper1 and silk still no go. Looked at the svg again and discovered a transform scale (-1) on the pads. Removed that in pad 0 and 2 by copying the x y position from the tool bar and then blanking the transforn with xml editor which causes the pad to move. Moved it back to the original coords with the top tool bar and now those two pads appear in the gerbers. So transforms are you enemy. I suspect the part you cloned from may not work or it may have been your resizing of the pads (if you didn’t ungroup the change will be via transforms).



Thank you so much for figuring that out. It also taught me a new trick.

EDIT: Here is the fixed part if anyone needs it. 74HCT245
74HCT245.fzpz (14.6 KB)

Unfortunatly Apply transforms doesn’t always work. It tends to die with a python error or sometimes appear to complete but not remove all the transforms, but yes it is useful if it works (I’ve more or less stopped using it because it doesn’t work for me in the cases I need).