Looking for help with a 12*12 tactile switch

Hi, I’m a new user here. Hoping to get some help with a part.

I’ve been rough designing using the Sparkfun Push Button switch. The “ksa_sealed” variant works perfectly, with 4 through-hole leads connecting properly. However, when I switch to the “12mm” (which will be the final piece used in my circuit) some things seem broken. The breadboard mode shows the switch on a breakout board, which is a hassle, but I can work with that. However, only leads 1 & 3 are useable, and the schematic doesn’t show leads 2 & 4. The Connectors tab in Editor only list 2 connectors. The end result seems to be that I can’t connect one of my legs to Ground. I mean, I can physically link them in Breadboard mode, but it doesn’t show as connected in PCB. Hoping this is just a quick fix that someone might be able to help with.

Ideally, it would look and act like the “ksa_sealed” piece, but be 12*12mm

This is the piece I’ll actually be using:


I’m unclear why you care. The switch is SPST so there are only two pins active (which the part supports.) It drills the holes for all 4 pins in pcb but won’t connect to them as they don’t exist as connectors. Just use the two active pins.


I really don’t care about the appearance. My main problem was: “The end result seems to be that I can’t connect one of my legs to Ground. I mean, I can physically link them in Breadboard mode, but it doesn’t show as connected in PCB.” I apologize if that part got muddled in my request. I wasn’t even getting a dashed line in PCB mode after connecting to pins 1 & 3 in Breadboard mode.

After having tried to delete and reconnect wires a few time with no success (to pins 1 & 3), I started to see what else might be wrong, and noticed the differences between pieces. Then I posted my request.

This morning, I deleted the wires and recreated them 2 more times, and the dashed connection eventually showed up in PCB mode. I was then able to route my connection properly. Same thing I tried last night, so I’m not sure what I did differently. I’m glad it’s working, though.

Thanks for your help.

The most likely answer is that you were using one of the non active pins in breadboard or schematic (which will not cause a rats nest line to occur in the other two views.) The best bet in such a case is to upload the .fzz file of the sketch (upload is 7th icon from the left in the reply menu) so we have the actual sketch to look at.


a couple of other tricks that will help

although it isn’t particularly useful in this case because it illuminates the end of the wire, right clicking on a connection will illuminate everything that is connected in yellow.

In this case the normal view is more useful. The connection on the left (which is red) is not connected as the pin isn’t a connector. The one on the right (which is green) is connected. That reflects like this in schematic

There is no rats nest line to the right top connection because there isn’t a connection there. There is on the bottom right connection because it is connected as indicated by the green connection in breadboard. This is likely the source of your problem. The lack of a connection in breadboard leads to no rats nest line in schematic.


Thank you for taking the time to explain that.