Installion Instruction [Solved]

I was using the version 0.9.3b from Ubuntu Software and then decided to update it with version 0.9.4, I have downloaded the tar file from github and now i don’t know how to install this to my system, i tried with terminal by typing “./fritzing” but it said no file or directory.

edit1: I figured it out but now it throws second error as :slight_smile:

Welcome aboard! The file on github is the source, you would need to build it to get a release (which is a very non trivial task.) To get an installable version go to the Fritzing downloads page at

the donation avoids you needing to build from source (and thus is well worth it in my view!)


Hello vanepp,
Thank you for the reply, I just downloaded the “tar.bz2” frile from fritzing/download/
Can you now tell me a way to install it into my Ubuntu 20.04LTS system?
also note the file name is quite unusual,

Just unzip it in your home directory. When you change in to the directory you will find a fritzing binary, from a terminal ./Fritzing should launch it and then you can add it to the native launcher by clicking in the “keep” button on the launch icon (or add the binary to the launcher if you know how to do that.) The odd file name is because of the new build process. The build tool chain had to be completely recreated for the 0.9.4 release as the old tool chain is no longer available. On startup Fritzing will access github to check the parts file is up to date (it should be already I expect) and may appear to hang. Do not interrupt it as that will likely corrupt the user directories and cause problems, just wait for the update to complete (it does not have a progress message at present.)


I did exactly you told me to but then again, same error.


these are the content of the folder upon extraction from the archive, i notice a file in there, am i missing something?


Hello, I managed to solve this problem by doing a research on previous post and one actually worked, ehoitinga Posted a solution with this same problem on on 11 Dec 2019 on GitHub.
The problem was the library itself was missing from my system and for some reason Fritzing was not looking for the library in it’s folder, I don’t know to be exact so correct me if i am wrong, Installing these libraries with the given command;

sudo apt-get update
sudo apt-get upgrade
sudo apt install libqt5printsupport5 libqt5xml5 libqt5sql5 libqt5serialport5 libqt5sql5-sqlite

Solved my proble, After giving this mess a whole day i finally made it.