Installation into a Raspbian Raspberry PI 3 B+


Today I successful installed the latest Fritzing Version file, fritzing-0.9.3b.linux.AMD64, onto a Rapsbian Raspberry pi 3 B+ computer which I bought in this month, Jan/2019, by " sudo apt-get install fritzing ". But the fritzing did not start and stopped if I tried again.

I can see the following message after entering “fritzing ,return”,

[email protected]:~ $ fritzing
libEGL warning: DRI2: failed to authenticate qt5ct: using qt5ct plugin inotify_add_watch(”/home/pi/.config/qt5ct") failed: “No such file or directory”
Segmentation fault".

Can someone please let me know how to start the program correctly ?


I expect the answer is that you can’t. As far as I know Fritzing only supports amd64/Intel architectures (Linux, Windows and Macs). Ther Raspberry PI is an ARM. While it should be possible to compile the source for an ARM (assuming Qt supports ARM which I expect it does), I don’t know of anyone having done so though. There are past forum posts about cross compiling but you would have to build from source (which isn’t currently working) though I expect. The am64 version isn’t likely to work (although I’m not an expert on PIs either).




Thank you for your quick response and advice. This installation is too difficult for beginners of me. I understood that it would be better to give up. Again, thank you.



When I searched earlier I used arm as the search term and didn’t find anything. Just now I tried
“fritzing on raspberry pi” in a google search which turns this post up. There apparently is a port of Fritzing 0.9.3b in one of the raspberry pi repositories (looks like not the default one though). You may need to also load the fritzing parts package if Fritzing complains it can’t find any parts (that has happened with some of the AMD64 linux repositories, don’t know if it is true here).

Good luck! Alternately Fritzing runs on PCs (Windows, linux or Mac).



Thank you. I decide to use Fritzing on PC, win.



That is certainly easier and has more support if something goes wrong, the RPI port may work just fine, but I don’t know if anyone in here is using it.



hi guys Im new to all of this, and I’m working on an experiment with a Raspberry Pi.

Our intent was to build the components and wiring on fritzing, and then put the code into it as well, and then simulate whether a) we’ve wired things correctly, and b) whether our code is correct, prior to actually buying physical components and uploading the code into Raspberry Pi.

After reading the above, I wanted to double check if my understand of Fritzing is correct and whether what I just mentioned can be done here? or should I be looking at a different software to try and digital prototype this thing we’re making?

thanks in advance!