Importing a KiCad part footprint?

I have searched and seen mention of importing KiCad part footprints.

I have a custom footprint that I would like to use in FZ. But I can’t find how to import it?

Is it still possibl



Welcome aboard! Looking at the forum posts (all archived in the old forum) there doesn’t appear to be a KiCad to Fritzing converter. I looked at KiCad, then found Fritzing and never went back, so I know little about KiCad. I see there is (or was 5 years ago) an svg export option in KiCad. That would be your best bet (as Fritzing footprints are a svg file.) You would need to add the groups and connector names that Fritzing wants but that isn’t too difficult (at least for me :slight_smile: .) To make a full part you will also need breadboard and schematic svgs.


Exporting SVG from Kicad is only available at the PCB level, meaning, can only export the PCB, not the Footprint.

I’ve made about 30+ Kicad footprints and a bazillion Fritzing parts and custom PCB’s.

See my posts on making custom PCB. Peter is the Parts expert.

IMO it’s quicker and easier to start from scratch rather than cobble/force something up from existing parts/pcb’s.

Search this Fritzing site for my posts and here, if interested, is a link to video I just posted for making a Kicad Footprint using FreeCad.

In looking for something else, I came across this:

apparently you can import kicad footprints (which I wasn’t aware of.) I don’t know if this still works, but it may be worth a try.


I agree with @opera_night, easier to just make it from scratch (or adapt existing part) than to try messing around with importing. What @vanepp posted is interesting, but I wouldn’t want to spend anytime figuring out how to use that.

I just went through the same sort of thing 2 nights ago, trying to import a PCB .svg file into fritzing. I worked on the file in inkscape a few times trying to get the file so fritzing would accept it correctly. Took me 1/3 the time to just make it from scratch in inkscape…

Just my thoughts,

Being lazy, I’ll likely try the import function out. I did a SOT23-8 footprint (which turned in to the whole part) for someone recently, and while it was easy enough to do by finding the data sheet with the footprint and making the footprint in Inkscape, I suspect being able to generate that footprint from an existing (assuming there is one) Kicad footprint would have been easier yet. Since the code hasn’t been touched since at least 2016 and possibly earlier, it may have problems with current Kicad footprints if there have been changes but I think worth a try. If it doesn’t work, it should be on the development enhancement list as it would be useful.


So I tried it this morning. Doesn’t appear to work, and so far doesn’t give any indication why not. I found the kicad footprint library with the sot23-8 footprint I made and downloaded it. Made a test directory for Fritzing (0.9.4) and opened a DOS window and ran

C:\fritzing\fritzing.>Fritzing -d -kicad Package_TO_SOT_SMD.pretty

where Package_TO_SOT_SMD.pretty is the kicad footprint directory which is in the Fritzing directory. It completes almost instantly (and the footprint file has many footprints so this is likely too fast!) with no useful debug information. It appears debug data is being written to the user directory

but all that contains is:

translation en_CA loaded 1 from C:/fritzing/fritzing.

as opposed to:

translation en_CA loaded 1 from C:/fritzing/fritzing.
registering font family: Droid Sans DroidSans
registering font family: OCRA OCRA
got transaction
referenceModel::loadAll completed
parts count 2155
load something
checking for backups
check files to load 0
create empty sketch
loading bin ‘Core Parts’
module id mystery_part_sip_3_100mil not found in database
module id generic_ic_dip_8_300mil not found in database
module id generic_female_pin_header_2_100mil not found in database
module id generic_shrouded_pin_header_10_100mil not found in database
module Mystery Part - 3 pins:mystery_part_sip_3_100mil obsolete svg C:/fritzing/fritzing.
module Generic female header - 2 pins:generic_female_pin_header_2_100mil obsolete svg C:/fritzing/fritzing.
Setting platform to Arduino
updating link
Setting board to Arduino BT
Setting board to Arduino UNO
Setting board to Arduino UNO
Setting board to Arduino UNO
Setting port to COM1
adding layer kin 57661 3 25 11fbe710
adding layer kin 57662 3 18 11fbe940
finish up sketch loading
http check new version
http check new version no error

when I run

C:\fritzing\fritzing.>fritzing -d

(which launches Fritzing normally) so it looks to be exiting (silently!) on an error of some kind.

@KjellM @microMerlin have either of you run Fritzing in server mode and have any suggestions? Other wise I guess it is fire up the development environment (which at the moment means rebuilding it here :slight_smile: ) and do a trace some time in the future.


1 Like

No help from here. I looked over the information about server mode, but some of its limitations meant it was not currently useful for my workflow. I have never fired it up.

Found the problem. The extension of the kicad footprints (and maybe the format as well) has changed from .mod to .kicad_mod. A gdb trace on 0.9.3b on my development machine tells me this. Fritzing is looking for .mod files and all that is in the directory are .kicad_mod files, so the file list comes up zero and the server quietly exits with no complaint. Now to see what has changed from .mod to .kicad_mod (and maybe find some .mod files to try and see what happens.)

edit: This looks like a rainy day project :slight_smile: I found a document the details the two file formats .mod (which is apparently also a music file of some kind) and the newer .kicad_mod format which looks to be very different.

The Fritzing code would need a fairly large rewrite I expect. I haven’t found any old .mod files to see what the output from Fritzing looks like, but I think I’m going to give up for now.