I mistakenly connected a ground wire from my motor driver to the 5v pin of the Arduino and now the 5v pin doesn’t work

Hello there, pls I need help. Earlier, I was trying to control a small dc motor with my Arduino uno and l298n motor driver module. When I uploaded the code, nothing worked. So I decided to cross check my connections and found the culprit. I mistakenly connected a wire from the ground(gnd) of my l298n motor driver module to the 5v pin of the Arduino. Now the pin doesn’t supply any voltage. Please what should I do? Any help would be appreciated. :pray:

Best case: that pin’s dead. Worst case: your Arduino is dead. Either change your code to use a different pin, or buy a new Arduino.

Just connecting 5V to ground shouldn’t do damage, the voltage regulators are current limited (although the USB port is probably not.) As to what to do I’d try removing all the wires except the power (wall wart or USB) to the Arduino power led comes on and see if the Arduino is recognized by the IDE. Try powering it from a wall wart if you are on USB. Try another USB port if you are powered by USB (that would indicate that the original USB port may be blown.) If none of that helps then you have likely blown the Arduino (and possibly the USB port too) and need to replace it.


Thanks for the reply. The Arduino still works perfectly. I’m a beginner still learning, I just figured out the problem. I was using a breadboard and I forgot to connect the ground from one side of the breadboard to the other. Now it works😃

Thanks for the reply. Nothing was damaged, it was just my silly mistake. I’m a noob