I face Error in installing

i face when want to install fritzing error api-ms-win-crt-runtime-l1-1-0.dll
and i use win7 and i tryed to setup visual c++ redist and before finishing i see this message
what the solution pleaase .

Hi Mohammed, please try downloading a fresh copy from fritzing.org/download and try again. There were some issues with the Windows release that should be resolved now.

Hi, I just installed new copy on Windows 10 64bit and Fritzing still freezes when anything is clicked.

I get the same error " api-ms-win-crt-runtime-l1-1-0.dll is missing" even after repeated downloads.
Previous versions of Fritzing work fine.
What to do?

And I have this problem too. 0.9.2 starts well but 0.9.3 cannot start. I have fresh download. Win7 russian

Hi.
I downloaded the following Microsoft update:
http://download.microsoft.com/download/9/3/F/93FCF1E7-E6A4-478B-96E7-D4B285925B00/vc_redist.x64.exe

Solved the problem, for me. I’m on W7 x64.

For 32bits: http://download.microsoft.com/download/9/3/F/93FCF1E7-E6A4-478B-96E7-D4B285925B00/vc_redist.x86.exe

1 Like

I just downloaded the latest Fritzing version minutes ago and have this problem too.

My Win7 64 SP1 with the old Fritzing installs it fine without the additional MS api file, but my other clean Win7 64 SP1 wanted the file. I loaded the above file and installed - I rebooted here, but I don’t think it’s necessary -, but when I started Fritzing it looked like it froze. The thing is it doesn’t freeze, it’s actually downloading files and you have to be patient until it’s finished, From then on it starts normally. Make sure your firewall doesn’t block accesses to FZ or it may look frozen.

Hi NelsonB,

Thanks for your help. I have Win 7 64bit operating system and couldn’t install fritzing.0.9.3b.64. After installing the VC++ redist.x64 problem is resolved.

Hi
I’m very new to all of this. I’ve tried several downloads of Fritzing for Windows 64 bit today. It won’t start because files Qt5Svg.dll and Qt5PrintSupport.dll are missing. I’m running Windows 10. Any help would be greatly appreciated.

I am having the same issue. I can’t install the program, I have been all over and tried a few things including whats already been suggested on this blog. I have windows 8.1. I’m really interested in using this program, hopefully someone can help me with this.

What kind of error are you getting? The missing dll one or something different? One thing to try is delete the Fritzing tmp directories which on Windows are in

c:\Users\windows_username\AppData\Roaming\Fritzing

(where windows_user is your windows account name and this is a hidden directory so you need to enable displaying hidden directories in explorer) and

c:\Users\windows_username\My Documents\Fritzing.

reinstalling the zip file does not affect these two directories and if something gets corrupted in them that can block the installation. Fritzing will recreate them if they don’t exist. You might also try disabling Antivirus when installing in case your AV is deciding something in Fritzing is a virus.

I’m getting the missing dll and those file locations don’t exist one my com. My anti-virus software hasn’t come up as a problem yet. So still stuck. Thanks for responding so fast.

Yep if you are getting the dll error then those files likely won’t exist yet as Fritz hasn’t actually started yet. I’m of somewhat limited help because I’ve never had this particular problem (some other packages I use on Win7 install the C runtime package already). If you search for dlll here in the forums you may find a solution that works (most everyone else has I think, or they have given up and stopped posting :slight_smile: ). XP is I think a problem but I’d expect 8.1 to work if you get the run time in. I remember someone posting a link to a source for a patch at Microsoft that fixes this which should be back in the forums somewhere. Good luck!

I remember someone saying that their anit-virus stripped files out of their download, if that helps.

ok deactivating the anti-virus software let me open the program but it froze when I clicked on it. I’m getting closer, thanks for the help so far. any idea what I can do now?

Wait :slight_smile: whats happening is it is doing an update from github of the parts data base. Someone found that preinstalling git makes this much faster but the standard solution (assuming you have a network connection so it can get to github) is to just wait til it completes. I’ve heard of times as long as 15minutes or more but for me it is usually just a couple of minute. Good to hear of progress and that AV is a potential cause (most folks just go silent and don’t tell us if it worked or not :slight_smile: ).

Yeah it does a download without a progress bar, so you don’t know it’s doing something, so just let it sit for a while.

During the installation of Windows 10 you may face different types of errors that can be generated because of the different causes.

Some of them are:

  • Windows 10 Update KB3201845 Issues
  • Windows 10 Anniversary Update Error 0x8007042B – 0x4000D
  • 0x80248007 Windows Update Error in Windows 10

To know the solution about these or any other update errors you need to visit:
24 Most Common Windows 10 Activation Error Codes and their Fixes

возникла такая проблема, как решить, не пойму. установка на win8.1