I can't open any sketches files

Hello, I just downloaded Fritiz yesterday and I was working on a sketch, today I was trying to open it but it gives me this error

Unable to open ‘C:/Users/ana-a/OneDrive/desktop/
Untitled Sketch 2.fzz’: zip.open(): %d

I tried to create a new sketch and save it to see if there was a problem on the previous file but still the same, even the new sketch is not opening.

Check the size of the sketch file (the .fzz file.) It is likely 0 and thus doesn’t exist which is the typical reason for this error. For some reason Fritzing can’t write in to the desktop (likely because of OneDrive which has caused problems in the past) so the first thing to try is to save the sketch to somewhere local to your machine’s drive (i.e. not on OneDrive) and see if that works. Assuming that works you have a problem with OneDrive which you need to fix.


I haven’t saved it on One Drive, actually I am turning the synchronization off, I saved the file into the desktop so it shouldn’t be the problem I guess.

Windows appears to be storing the file on OneDrive

"C:/Users/ana-a/OneDrive/desktop/Untitled Sketch 2.fzz

which as noted has caused problems in the past. Check the size of the file above, it is likely 0 in which case the sketch won’t open. Try saving the file to somewhere on you C: drive where you can write (assuming you have something writable in your C: drive) as that should work (as technically should OneDrive but as noted there have been past problems with OneDrive not working correctly.)

C:/Users/ana-a/Untitled Sketch 2.fzz

and verify that works (which will indicate a OneDrive problem.) If that doesn’t work you appear to have another type of permission problem as it appears the sketch file can’t be successfully written and then read by Fritzing.


Yes sorry didnt pay attention to that.

I checked the size of the file, actually it’s not 0, the size is 5.71KB and 8KB on disk.
In that case since it’s not 0 is there a possible way to make it work and be able to open that file?

If you upload the .fzz file (upload is 7th icon form the left in the reply menu) I can have a look at it and see if it is recoverable (and try it on Fritzing here to see what happens.) The error usually means that the .fzz file (which is a zip file) is corrupted and thus not recoverable, but it may be with some work or there may be a problem with your install and the .fzz is fine.


Untitled Sketch 2.fzz (5.7 KB)

There it’s, thank you so much for your assistance.

Well that turned out easy. For me the sketch loads fine.

which says there is something wrong with your installation. Things to try are reinstall Fritzing after clearing the user directories (although that hasn’t been much of a problem in recent years it is still probably worth trying!) here are the instructions for clearing the user directories (note this will delete all your custom parts so save them as .fzpz files so you can restore them or move the directories aside)

There are two user directories (with your parts and the parts database) which don’t get touched during an install (to not affect your sketches during upgrades). On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

If you don’t have any parts or sketches you want to keep you can just delete those two directories and Fritzing will recreate them, or you can move them aside by renaming them if you want to keep something in them.





Try shutting down OneDrive if you can easily before doing the install may also help. As noted I think OneDrive usually works (I don’t use it, so I don’t know!) but there have been some issues in the past. It appears something on your system is causing the .fzz file to be not readable although the uploaded file is readable here, so the file looks OK, just something on your system has a problem. You might want to try unzipping the .fzz file (I use 7zip but any unzip program should work) the unzipped file should look like this


It’s working now, thank you so much!

Do you know what fixed it (in case someone else has the same problem?)


I deleted the program and redownloaded it again, but the main step was as you mentioned is to save it somewhere else outside of that OneDrive. I tried making a new one and save it somewhere else than OneDrive and they were working 100%.

I suspect there was/is a permissions problem with the OneDrive files, but I don’t know where or how to fix it. As long as you have a solution that works for you, things are good.


Just a note to anyone encountering this problem, I had the same issue after a new installation where Fritzing would only try to look in OneDrive for files and give an error.

The solution for me was to allow access to Fritzing. Normally a pop-up dialogue appears when a program tries to access something it doesn’t have permission to, but in the case of Fritzing this wasn’t the case.

  1. Go to: Start>Settings>Privacy>File System
  2. You can then choose to add Fritzing to the apps allowed access to the filesystem.