How to exclude a pin from autorouting

I tried to make a PCB having an Arduino Pro Mini on it. This has on the smaller side pins for the signals GND, VCC, RXI, TXO. However, these are usually not connected to the board, as they are used for programming. So, either those have pins connected on top or are not connected at all.
Note, that these signals are also available with pins on the larger side of the Pro Mini. When the Autorouter is run, it makes connections not only to VCC on the larger side, but also to the VCC on the smaller side, i.e. that for programming the Pro Mini.
I could overcome this situation by drawing a connection by hand. But is there maybe a way to stop the Autorouter making connections to certain pins?

Thank you!


Try editing the Arduino pro mini in the parts editor. In the right hand side dialog box, look just below connections for a check box that says “set internal connections”. Check that box, and make sure those connections are correct in PCB tab inside parts editor. I was just looking @ the preset wires on the Pro Mini that comes with my Fritzing, seems suspect as per your problem. Have a look, change those around. Should set the problem straight.

Good luck!!

Land Racer’s idea should work just fine if the parts main pins are defined as the ones you want.

I do wonder if this would mess up the pin count on your part causing problems later.

You could edit the part and remove the pins all together. This could clean up your pcb as you wont have unused holes on your PCB. This would be a fair amount of work if you are not used to editing Fritzing parts but it is an option.

You could

It would be nice it there was an option to make a selection of wires that you want to autoroute.

On an arduino select a a part and only autoroute THAT part, if that was possible then autorouting would make more sense.