How to create a dual row connector?

I’m obviously doing something wrong. I drag a connector from core in to breadboard and in inspector change row from single to double and pins to 8 expecting to get a 4 and 4 double row connector. In breadboard it remains an 8 row single connector, as it does in schematic (which may be normal) and in pcb it changes to a two row connector as expected. However if I then select the part in pcb and try and edit it with parts editor I get an error message about unable to read a temp file for Generic double female header - 8 pins generic_double_row_8_100mil not found (and it is entirely correct, there is no such file in the temp directory listed). So what am I doing wrong? I’d say this machine is corrupted except I cleared temp and deleted and reinstalled Fritzing (because I had been muddling around in core parts and may have damaged something) but the clean install does the same thing as do two other installations on Win7 and Win10 on a different machine that I hadn’t screwed with the Fritzing core directories on.

Peter

Yeah mine’s the same.

I pulled another 2 pin header into BB and tried 8 pin first, and double row second, and then things really went crazy in PCB. I ended up with a 2 pin, AND another muddled 8 pin.

How come no one has noticed this? We both have to be doing something wrong here I expect.

Peter

Not really, I don’t think we’re doing anything wrong. Grab a LED in BB, it should be 5mm red, change to 3mm, and now change back to 5mm.

I’m of the thought that a Windows patch must have broken the permissions and are blocking the script that writes the svg from creating it (but why it works for the fpz is a mystery then), as I can’t see something this basic not working at some point in the past. A look at the debug console isn’t illuminating, it documents the creation of the fpz file in temp but says nothing one way or the other about the svg (it in fact says nothing after the creation of the fpz which does exist in temp). I may try Fritzing on Linux and see if that works and this is only a Windows issue.

Peter

I don’t know much about that, but Racer said it was a 1 pin svg that gets assembled when you select the config in Insp. Don’t know how they do the PCB though.

I expect the same way a script (although since I don’t see anything likely in the script directory, perhaps the main program) copies the number of pins to a temp svg. The pcb part seems to be working, only bb is broken.

Peter

I must of got a part update, because when I tried it before the PCB view had a 2 pin header, PLUS there was a 8 pin header with the pins muddled and overlapping.