HopeRF RFM69HCW ISM Transceiver

I have created a Fritzing part of the ISM band transceiver HopeRF RFM69HCW (see the attachment).

HopeRF_RFM69HCW_ISM_Transciever.fzpz (11.2 KB)
HopeRF_RFM69HCW_ISM_Transciever_v1-1.fzpz (12.2 KB)
HopeRF_RFM69HCW_ISM_Transciever_v1-2.fzpz (12.4 KB)
HopeRF_RFM69HCW_ISM_Transciever_v1-3.fzpz (14.7 KB)

SVG Files v1.3

1 Like

I’ve only found this out a few days ago, but if you export your part in Fritzing’s Production Gerber Export it shows errors.

Basically Copper1 is missing, so you need to make a full duplicate copy of Copper0 and call it Copper1, and then put it inside Copper0

In Inkscape I open the XML editor and just duplicate Copper0, rename Copper1, and just indent it into Copper0.

There are no instructions for this stuff so I had to reverse engineer it from other parts, but one guy made group Layer1, then in it Silkscreen group with all it’s nodes, and then an empty of nodes Copper1, and in that he put Copper0 with all the nodes, and that passes the Gerber test.

Other things I have found out is that if the part body needs extra holes, like mounting holes, these holes have to be put in the Copper groups or they won’t get drilled.

Thank you for your notes! I will rename the copper group (probably tomorrow).
One of the hardest things to figure out was that the silkscreen group needs to come first (before the copper group) in the XML tree of the SVG-file. Otherwise the text and the lines will not appear in the current version of the Fritzing parts editor.

btw: I like to have SMD solder pads for rfm69hcw pcb on my cumulative pcb. That is why i have not made holes in the copper layer.

@ntm I wrote and entry that may help you understand the pcb layers a little better; Making pads without solder mask?

You also have some issues with your breadboard view… I will take a look at it to see what is going on here…

@steelgoose: I used these SVG files.


In the pcb,svg just change copper0 to copper1, For solder pads, you don’t use Copper0. Actually, I didn’t explain that correctly; On a one sided board, copper1 does not become copper0… copper1 becomes the bottom layer… if that makes sense… confusing…

I opened up /Fritzing/parts/svg/user/pcb/rfm69hcw_b27ca32e865419e633c496069cb18a17_2_pcb.svg in notepad++ and just changed copper0 to copper1 and it appeared to work correctly.

Your breadboard looks ok… If you wanted your RFM69 ISM Transceiver, to connect to the breadboard, you would need to make some changes.

You should also go to, http://fritzing.org/fritzings-graphic-standards/ and download and install the two fonts that are required in Fritzing; “OCR A or Droid Sans”.

Your parts are probably fine for home, it’s just if it went to production the Gerbers might not be perfect.

I’ve got parts with copper 1st and silkscreen 2nd so it might be something else.
I’ve seen copper0 inside copper1, copper1 inside copper0, no overall Layer1 group to house all the other groups, all I know is that you need 2 copper for production or Fritz will show errors when you export Gerber them.

I wish there was some instructions so we don’t have to fumble in the dark.

I just mentioned the holes if you do holes.I made the mistake of putting them in the silkscreen group, because that’s were I thought they had to be, but they don’t get drilled if they aren’t in the copper group.

Thanks for the help. I have made the suggested modifications. I adjusted also the measurements according to the datasheet of transceiver (I took measurements of the device without proper instruments for the first versions. Now (v1.3) it has the correct measurements.). Unfortunately the holes for the multi-pin connectors in this transceiver type do have not the same spacing as the breadboard. The spacing is 2mm and not 2.54mm as usual.

I was thinking that copper0 and copper1 were for top and bottom on double sided boards.

I think it’s better to always supply both copper0 and copper1 for every part because if it get used by someone else in production for a double sided board it will produce errors when you Gerber Export in Fritz.

That is correct, the breadboard spacing is 0.1" (2.54mm). If you want it to connect to the breadboard, you could mount it on another board a little larger then the Transceiver board and put the breadboard connectors pins in it with pin spacing in multiples of 0.1". You would need to move your connector pin to the new board and change them all the male pins.

In v1.3 I have renamed copper0 to copper1, because i had some problem while importing the svg with a copper0 group which includes a group copper1.

@steelgoose: I tried OCR A Extend which is inckluded in Win7. But that seems not to be the same OCR A Fritzing can handle. The appearance of the pcb.svg with OCR A Extended was very faulty. That is why I switched to Droid Sans (Apache License) which can be downloaded from Github Google Fonts.

@Old_Grey, @ntm, Hi Old_Grey, That would not work on every part… For through holes, both copper1 and copper0 are used so there is a copper ring on both sides of the board… On solder pads, if you place the pad inside of both copper1 and copper0, you would have a pad on both sides of the board. Fritzing claims with the new Parts Editor, at this time, you cannot place both through holes and solder pads on the same parts. Either through holes with copper1 and copper0 or pads with just copper1 but not both. Because, copper1 and copper0 are embedded layers… although, there is a way around it…

I didn’t think about SMD, sounds right.

That would cause some error msgs if you Gerber Export SMD parts so you have to just ignore them.

Sorry, looks like your parts were correct.

@Old_Grey, You can use both THT and SMD on the same part, you just need to place them in the embedded layers in the right place… see link.

I opened the new part in KiCAD Gerbview and it’s all on the top now, so it wasn’t a complete waste of time.

At least we leant something.

I didn’t realise the Fritz Gerber export has faults - it can’t define SMT and TH parts - because it still wants the missing stuff. I’ll know for next time what to ignore.

Now I’ve got to update my TH parts.

Check out Teensy 3.0+Pads in the Core parts… It has THT and pads on the bottom. Actually, you can have a part with THT and SMD on both top and bottom… you just need to go into the fzp and edited it by hand…

That sux that you can’t export core part files.

It’s file Teensy_3.0+pads_pcb.svg, and it’s done the old way with separate copper0 and copper1 rather than 1 inside the other - it gets error when you edit -.

I have made version which looks like the top view of the module which is in all the data sheets.
RFM69HCW_ISM_Transciever_v1-4.fzpz (15.6 KB)


Slight problem. The pins are only red on the tips In SCH, when usually the whole pin is supposed to be red. The colours designate connection, ie, red not connected, green connected, and being that small it’s hard to tell. I’m guessing you have a node on the tip that you are allocating a contact rather than the full pin, so it easier to assign. You can code the position directly but you would have to unzip a Vanepp part to know how to do it, because I only know the FZ Part Edit and compass selection method.
Also the PCB contact point is in the centre rather than the tip

Alright, i will fix that. I added small dots add the ends of the contacts in order to avoid the tedious work of setting each of 16 coordinates manually. (When i add a new version of the SVG, the contacts need to be selected again and again.)
I did not set the coordinate systems to the ends of the contacts with W or E. But now i will do that.