Ground Fill taking a lot of space

Hey there,

I wanted to design a pcb to manufacture it via PCB-milling.
When I add the ground fill as the last step the file size grows from ~4kB to ~500kB. Unfortunately the processing software to generate the g-code can’t handle the file with the ground fill.

Maybe it is possible to have the interrupted soldering pad without the ground fill algorithm manually?

I also asked the developer of CopperCAM if he has an idea. This is what he wrote:

The bases (GroundFill) consist of thin hatch lines. CopperCAM calculates the outlines for each, then the collisions with everything else, then the connections. This takes a lot of time.

The Gerber RS274X format allows direct generation of surface polygons with G36/G37 codes. You must use these polygons. There must be an option for this in the Gerber output.
(Translated with DeepL)

Should I file a bug report on github to export the ground fill as polygons?

Thanks for your help!

I’m on Linux with fritzing 1.0.2

Yes, filing an enhancement request on github is likely the appropriate answer.


I think this problem is solved in 1.0.2 using the new algorithm. Are you using the new as algorithm?

Just checked again, I’m on 1.0.2 and using the new algorithm.
I edited the initial post accordingly.

I wanted to fill an enhancement bug report and stumbled upon this one.

Do you think, this is the same issue?

In that case, I would also recommend to open a issue in the tracker.