Generic IC dosn't work

Steps I took that resulted in the problem:

when I Insert generic IC - changing the # of pins the part doesn’t do the changes in the part on the canvas

What I expected should have happened instead:

The forms blank the number of pins and the after a few second it return it to 8.

My version of Fritzing and my operating system: 0.9.7

Please also attach any files that help explaining this problem

I am still using 0.9.6, and it works for me with the provided information. I am using Fedora 33. Is that the Windows version you are using?

I can reproduce the bug in 0.9.7 (Windows), not in 0.9.6. Please, create a bug report in GitHub:

Reported as “Generic IC broken on 0.9.7 #3859” on fritzing-app issues on github.


It looks like 0.9.7 was quietly released a few days ago and that has broken the generic IC stuff (at least on Windows, haven’t tried the linux version yet but I would be surprised if it is different there.) Looks like the swapping code has bitten them to me, but I guess we will see.


I saw on slack that the new version was up, but have not gotten around to pulling down the AppImage.

I revert back to 0.9.6 and it’s working OK :slight_smile: on this version. Thanks for your help. Now i can continue working on my projects !!!
Many Thanks,

I am new to Fritzing, the first version I downloaded was 0.9.7 on Windows, and was disappointed to find out about this bug - first project I was trying to design and I can’t use a dip IC, very frustrating, and I don’t have a previous version I can revert to. Will this bug be fixed soon?

It is fixed, i am currently signing the releases. There is a delay on macOS, but if that delays further I’ll upload the fix for Linux and Windows at least

As well, on the download page you can download version 0.9.6 where it works (although I found what may be an error case in 0.9.6 when changing the size of an existing part last night.) Waiting for the fixed version of 0.9.7 is probably the best bet though.


I am a new user on Mac OS and I get this error:

Parse error (2) at line 1, column 1:
unexpected end of file

I’m stuck - will a new MAC update be available soon to fix this please?



Forgot to explain when I try to change number of pins on generic IC!!

As Kjell’s post above about the fix said there will be a delay for the Mac version due to signing (perhaps Apple has to approve the signing?) so your choices are to wait for the new version of 0.9.7 or downgrade to 0.9.6 which works and should be available on the bottom of the downloads page in the previous versions section.


Woohoo, 0.9.8 now appears for MacOS - downloaded and it works - very happy bunny here :grinning:



I never thanked you for the quick response. I have 0.9.8 and it worked great.