Fritzing now crashes on my Pi (running Raspbian O/S)

Steps I took that resulted in the problem:

…Hi , I have Fritzing on a Raspberry Pi 3 running raspbian O/S. Fritzing worked until I loaded some parts fzpz files into it. Now it crashes instead of starting up . I can’t get any feedback error messages. Can I run it in some kind of diagnostics mode to see why it won’t start up now ?
Can I somehow get rid of these extra files if they are the cause of the crash. I can’t find them or a folder for them.

What I expected should have happened instead:

I expected Fritzing to start up like it had been doing until I imported in some fzpz files .

My version of Fritzing and my operating system:

fritzing 9.0 and Pi’s raspbian operating system.

Please also attach any files that help explaining this problem

The most likely problem is corruption in the user and/or temp directoies which on linux are supposed to be in ~/.config/Fritzing. If you rename this directory Fritzing should recreate a new version of it (and wipe out any sketches that you already have which is why to save a copy). Also the latest version is 9.3 so you may want to try and upgrade as well (although there may not be a version of 9.3 for the PI yet). Good luck!


Hey we can mark this one as solved for future Pi users :slight_smile:
I read another Mac users problem and found that he needed to turn off networking due to github interference. Now I did have it turned off, and on my last boot I noticed a VNC icon had popped up again. So I went into raspiconfig to turn off VNC again. After a reboot Fritzing now comes back on. I do some programming myself and I like to have some kind of dire “I am going to die because …” message show up before my program ends up dying (or as an after death message written to console) .

It seems that sometimes programs including Fritzing are not opening up after I use and close up Fritzing ,but after a reboot brings everything is back to normal.

Seems this bug keeps on coming back to me. Nothing to do with networking at all it seems. It crashes also sometimes while I am using it. Right now , it won’t start up again like before. I will try wiping out any ~/.config/Fritzing folders to see if it will start up again.

You might try doing a ps -auxw from a console window and see if perhaps Fritzing (or other applications) aren’t exiting successfully and are holding files open that block new starts. The stray tasks will get killed on the reboot. If there look to be stray tasks after you close Fritzing you can use the kill command with their pid to kill them and see if Fritzing will then restart without the reboot (just be careful that you know what you are killing :slight_smile: ).


Well , I thought I had been experimenting with other software so much that the O/S got corrupt. It finally would not open any of my software Qt Creator , Fritzing and others .Sooo I reinstalled O/S and got latest version of everything ,including O/S. Everything works again so far. Maybe when I was trying out the OPENGLES stuff it started the crashing process. A new desktop PIXEL is out and who knows how well it handles the graphics. Also my own code can go crazy some days. Don’t know why :slight_smile: all this can be very bad for an O/S in development.

There are lots of possible failure modes, including flaky hardware (such as memory errors). I’m assuming you are booting from an SD card so it too is a candidate if it got some bits corrupted that will cause problems (and if a reload cleared it that is somewhat likely). In any case good luck!