Fritzing file ruined

Steps I took that resulted in the problem:

I worked and saved occasionally. All of a sudden I get warning messages when I save. I cannot tell what I exactly did but I edited some of the texts on the components. Nothing really advanced actually and the PCB I was working with wasn’t anything fancy, a Mega shield with connectors etc. I close the file and try to open it again and receive:
Unable to open ‘/Users/Staffan/Documents/Fritzing/Gunde Mega Shield.fzz’: %d

What I expected should have happened instead:

Well, The program to continue work I guess. A whole evenings work is destroyed since I even can’t go back in time and open to the point where I was when I encountered the problem. (and what the problem was I really cannot tell)

My version of Fritzing and my operating system:

Fritzing 0.9.3 Mac Os 10.13.6

Please also attach any files that help explaining this problem

Gunde Mega Shield.fzz (22 Bytes)

This is a known bug but unfortunately Fritzing development has stopped and we can not get a hold of anyone that can make a new release even if we do patch it. It has happend to me and I have lost weeks worth of work to it. My solution is to make a back up of the fzz files at least daily while i’m working on a project.

The only way of saving a project when this happens is to NOT close Fritzing and then select everything in a single view and press ctrl c to copy everything and then paste it all in a new sketch which you will be able to save.

I’v had FZ crash and shutdown, losing everything to the last save, but never corrupted files.

I tried the unzip trick to see if there is anything inside, but it’s just an empty folder.

Thank you for the reply and to offer a solution. It is pity that Fritzing isn’t developed since it is a great for us hobbyists and also the unofficial standard to make illustrations in different maker communities. Anyway, I have respect that people do the work mostly also are hobbyists and sometimes life changes and there isn’t any time for development.

While this is a known bug (at least on Unix, I’ve never seen it on Windows) as far as I know we don’t know how to make it happen (which would be needed to find a fix). The best workaround is to copy the user directories as a backup on a regular basis.

On linux (and probably the Mac too I expect) these are:


On Windows they are in

c:\users\username\AppData\Fritzing\roaming\Fritzing (which is a hidden directory so you need to enable hidden directories in explorer) and

c:\Users\username\My Documents\Fritzing (where username is your windows id)

It is possible to corrupt one or both of these (usually by interrupting a parts update) and
they sometimes need to be deleted. Copying them to a backup copy allows you to
move them back in to the original place and carry on, so having a backup copy is good insurance.