Fritzing Edit acting weird

Can anybody work out why if you right-click/Edit this part in MINE bin there is NO error, but if you add it to the PCB view and right-click/Edit the part it gives a separate copper error. The only thing I changed was the PCB svg, and if I take that same PCB svg to the 74HC595 IC it doesn’t error. I’m thinking the svg is ok, and that maybe it’s in the .fzp file.

DIP - 16 pins.fzpz (6.8 KB)

It may be the Transform attribute in the group layers; this has caused other idiosyncrasies in other parts…

<g transform="translate(0.6604001,-276.55523)" >
    <g >
        <g >
            <g id="copper1"  gorn="">
                <g id="copper0"  gorn="">
1 Like

That sucks when you export parts in FZ and it adds all that extra gs and gorns.

I don’t really know what to do with the transform, and I checked other drawings I did from scratch and they have transform, yet if I load it into a CORE IC it errors, but not in HEF7094 or 74HC595.

My svg


My Exported svg

<g transform="translate(0.6604001,-276.55523)" >
        <g >
            <g >
                <g id="copper1"  gorn="">
                    <g id="copper0"  gorn="">
                        <rect height="1.5320001" fill-opacity="1" stroke-width="0.5" y="277.43799" x="0.24999994" stroke-opacity="1" id="rect897"  gorn="" style="color:#000000;clip-

Exported IC from CORE

    <g id="copper1"  gorn="0.2">
        <g id="copper0"  gorn="0.2.0">

The gorn’s are created by Fz and has something to do with to order of things or something like that. I looked it up a couple of times… they don’t really seam to cause a problem. I sometimes delete them by creating a filter in notepad++… I don’t know where all the extra g’s come form. It is annoying, especially when they are about 10 layers deep. The transform comes from Inkscape; your image was rotated or transformed in someway. We ran across this before, When the transformed the surrounded entire copper group was removed, everything worked great. I believe he removed with Inkscape but I don’t know how he did it.

All those added g’s may be from your XML formatting… I never checked it so I am not sure. In Inkscape, click Edit / Preference, then under Input/Output / SVG output, under XML formatting, check the box next to Inline attributes… That may be the culprit… It would be interesting to find out… I believe there is also away to get rid of all that metadata at the top of your SVGs somewhere in one of the settings in Ink.

It’s all a bit too much for a tutorial, so I’ll have to fudge it.

How I made the part is in chapter5 tutorial and I didn’t do any transform rotate/scale, but I do notice if you change a node size with the toolbar and undo it, it does say something about transform. Don’t tell me you can’t use the arrow select size toolbar in INK.

I don’t really get why it works on some and not on others, because this is the first made from scratch part that didn’t work.

Thats what I have found. If I change the coords in Ink with the top tool bar it does a translate. The only thing I’ve found that doesn’t is to change the actual coord I want via xml editor, any of the graphic commands create transforms and your coords become scaled (and thus no longer accurate in the xml).

In Preference / Behavior / Transforms there are some transform settings… a checkbox that that is listed as “Transform patterns”, I don’t know what they do, but you could try playing around with these settings…

That sucks because I live by the coords, it’s the only way to be accurate.

If you ask me have a 3rd part external editor is killing FZ.

I spent a couple days reporting bugs in INK, and now I just finished an addendum PCB video that might be wrong if I can get Preference to work in INK.

We must have something setup different… I drew a rectangle and an ellipses, and resized them by the toolbar and handles and I don’t get a transformed… I do when I rotate.

Here is one of the problems… In Preference / Behavior / Transforms, under Store Transformation, click the button “Optimized”. If the button “Preserved” is punched, it will create Transformation when you resize it… Optimized won’t.

Mine is Optimized.
The other 4 boxes look the buttons on the top toolbar when you arrow select something.

Well I drew 16 contacts in INK without any transform - I freehand 2mm circles and changed the stroke to 0.5mm and duplicated them -, and still it errors in the PCB view but not in the bin using the CORE IC part that I’m basing it on.

I can’t believe this crap.

I ignore the on-screen error by using the part in the bin, which doesn’t error, and now I load a newly made SCH drawing that I did exactly the same way as yesterdays svg, and now none of the contacts work. It’s just one solid image like it’s all one path.

I load the new SCH drawing into the other IC that doesn’t error, and it works fine.

For some stupid reason my old made SCH svg in the error part is fine, but my new exactly that same one isn’t.

Another day wasted doing a video that errors half way through, so it all goes in the bin again.

It may be that you are hitting the problem that it is careless with deleting temp files. If so a workaround is to move aside the two Fritzing temp directories

AppData\Roaming\Fritzing* and
My Documents\Fritzing*

and start with a clean slate. I often do this when making parts as an error will often get remembered (and thus repeated) until I clear the temp directories. I usually do both to clear everything but you may only need to do one or the other.

What do you mean, delete them.

Do I lose MINE parts.

Yes, mistyped there sorry :slight_smile: . I started out right, if you move the Fritzing directories aside as in rename AppData\Roaming\Fritzing to AppData\Roaming\Fritzing_date then recreate the folder AppData\Roaming\Fritzing (and same with the one under My Documents) Fritzing will recreate all its directories on startup but empty. When you are done delete or rename the Fritzing directories again and then rename your original in Fritzing_date to Fritzing and your original setup will return. What I confused was recovering from an error when you are already in the temp directories, then it is enough to just delete the directories under the two Fritzing directories to start again (as you noted you will lose everything in them, but for me typically they are broken anyway). (edit) I should add that you need to shut Fritzing down before doing this so that it has closed all its files, and that it also keeps temp files in Appdata/local/temp but it doesn’t seem to care about those only the two data directories (and it may only care about one of the data directories).

I think it’s funny… lol… Are you having a bad day??? Blame it on Murphy…

I gave up on that error-part made from a CORE generic IC, and have now switched to the 74 series IC and it’s fine.

Now the stupid fonts.

I loaded the fonts from the FZ download a couple of months ago, but now when I use them FZ says they are the wrong font.

I remember them working soon after I installed them, but now they don’t work.

What a POC.

Finally got this mess sorted, and my vid finished.

Don’t use error-part, find an non error-part donor.
Droid Sans doesn’t work, but OCRA does.

Ah, didn’t think of that for the fonts. The graphic standard doc does say if you use text, use OCRA so I guess it enforces that. Looks like breadboard is either, and schematic is Droid SANS. Whats an error-part and how do you tell something is one?